Bug 9587 - ctermid segfault
: ctermid segfault
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/glibc-core)
: unstable
: all Linux
: P5 blocker
Assigned To:
:
: http://sourceware.org/ml/glibc-cvs/20...
:
:
:
  Show dependency tree
 
Reported: 2006-05-18 10:23 by
Modified: 2006-05-20 16:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-05-18 10:23:13
После сегодняшнего обновления, словил на всех серверах:
$ touch aaa
$ gpg -bsa aaa 
gpg: NOTE: old default options file `/home/rider/.gnupg/options' ignored

gpg: Segmentation fault caught ... exiting
Segmentation fault

соответственно git-tag -s тоже не работает!
------- Comment #1 From 2006-05-18 16:05:33 -------
uname -m?
------- Comment #2 From 2006-05-18 16:16:33 -------
$ gpg -bsa aaa 
gpg: NOTE: old default options file `/home/rider/.gnupg/options' ignored

gpg: Segmentation fault caught ... exiting
Segmentation fault
$ uname -m
i586

Одинаковое поведение и на x86_64
------- Comment #3 From 2006-05-18 22:54:06 -------
$ cat ctermid.c 
#include <stdio.h>
int main(void) { return ctermid(NULL) != NULL; }
$ gcc -g -Wall -W ctermid.c -o ctermid
$ ./ctermid 
Segmentation fault
------- Comment #4 From 2006-05-19 03:03:34 -------
Fixed in 2.3.6-alt6.
------- Comment #5 From 2006-05-19 03:21:03 -------
*** Bug 9593 has been marked as a duplicate of this bug. ***