Bug 9640 - Неправильная зависимость на ghostscript
: Неправильная зависимость на ghostscript
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/ImageMagick)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-05-31 06:31 by
Modified: 2007-01-01 21:53 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-05-31 06:31:22
Неправильная зависимость на ghostscript, из-за которой при попытке установить
ImageMagick следом ставится cups.

From devel@:

inger@

> > > cups-common исчез только в самой последней сборке, смысла в нём
> > > особого нет ибо он всегда ставился и без него cups всё-равно не
> > > рабочий. Новая версия имеет нужные provides/obsoletes, не знаю отчего
> > > у apt'a так хорошо снесло крышу.
> > 
> > Тут вот какая цепочка зависимостей выстроилась:
> > 
> > cups (cups-common) -> ghostscript-drivers -> ghostscript -> ImageMagick
> > -> gqview
> Ага, спасибо, я посмотрю почему drivers стали зависеть от cups.
Посмотрел, да действительно drivers зависят от cups, но ...
пакет ghostscript виртуальный для обратной совместимости, если ImageMagick
будет
требовать пакет ghostscript-rip, всем будет лучше, поэтому можно повесить
соотв.
FR на ImageMagick.
------- Comment #1 From 2007-01-01 21:53:18 -------
исправлено в 6.3.1-alt3