Bug 9648 - undeclared file conflict with freetype
: undeclared file conflict with freetype
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libfreetype-demos)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-05-31 16:52 by
Modified: 2007-03-17 16:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-05-31 16:52:40
Пакет libfreetype-demos конфликтует по файлам со старым пакетом freetype,
однако
в зависимостях этот конфликт явно не указан, что приводит к аварийному
завершению установки пакетов через apt.
Steps to Reproduce:
# apt-get install libfreetype-demos
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
  libfreetype-demos
0 upgraded, 1 newly installed, 0 removed and 0 not upgraded.
Need to get 0B/8987B of archives.
After unpacking 50.9kB of additional disk space will be used.
Committing changes...
Preparing...                            
###################################################################################################
[100%]
file /usr/bin/ftdump from install of libfreetype-demos-2.2.1-alt2 conflicts
with
file from package freetype-1.3.1-alt4
file /usr/bin/ftlint from install of libfreetype-demos-2.2.1-alt2 conflicts
with
file from package freetype-1.3.1-alt4
file /usr/bin/ftstring from install of libfreetype-demos-2.2.1-alt2 conflicts
with file from package freetype-1.3.1-alt4
file /usr/bin/fttimer from install of libfreetype-demos-2.2.1-alt2 conflicts
with file from package freetype-1.3.1-alt4
file /usr/bin/ftview from install of libfreetype-demos-2.2.1-alt2 conflicts
with
file from package freetype-1.3.1-alt4
E: Error while running transaction
------- Comment #1 From 2006-05-31 19:51:02 -------
исправлено в alt3
------- Comment #2 From 2006-08-29 21:52:32 -------
Не вижу исправления:

file /usr/bin/ftdump from install of libfreetype-demos-2.2.1-alt6 conflicts with
file from package freetype-1.3.1-alt4
file /usr/bin/ftlint from install of libfreetype-demos-2.2.1-alt6 conflicts with
file from package freetype-1.3.1-alt4
file /usr/bin/ftstring from install of libfreetype-demos-2.2.1-alt6 conflicts
with file from package freetype-1.3.1-alt4
file /usr/bin/ftview from install of libfreetype-demos-2.2.1-alt6 conflicts with
file from package freetype-1.3.1-alt4
E: Error while running transaction
------- Comment #3 From 2007-03-07 11:57:46 -------

*** This bug has been marked as a duplicate of 9020 ***
------- Comment #4 From 2007-03-17 15:27:11 -------
хотя нет
------- Comment #5 From 2007-03-17 15:28:37 -------
исправлено в 2.3.2-alt1