Bug 9695 - ifenslave + bonding in 2.6.16-vs26-smp-alt8 = trouble
: ifenslave + bonding in 2.6.16-vs26-smp-alt8 = trouble
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/iputils)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-06-13 16:03 by
Modified: 2008-03-13 23:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-13 16:03:22
Не работает /sbin/ifenslave из iputils-20020927-alt4 - отказывается
переводить интерфейс в SLAVE.

# /sbin/ifenslave bond0 eth1
SIOCBONDENSLAVE: 1 (Operation not permitted).

ifenslave, собранный из kernel-doc-std26-2.6.16/networking/ifenslave.c,
работает так, как и ожидается - т.е. интерфейс eth1 нормально подключается
к bond0 как SLAVE.
Steps to Reproduce:
1. # modprobe bonding
2. # ifconfig bond0 172.16.1.1 netmask 255.255.255.0 up
3. # ifconfig eth1 down
4. # ifenslave bond0 eth1
------- Comment #1 From 2006-06-26 15:35:49 -------
Старый ifenslave в пакете, наверное.
------- Comment #2 From 2006-09-17 04:26:50 -------
Кстати, готов поделиться этой багой с кем-нибудь.
------- Comment #3 From 2006-10-15 16:17:00 -------
Занесено в rsync://git.altlinux.org/people/mike/packages/iputils.git
[20020927-alt4.1]
------- Comment #4 From 2006-10-16 02:51:44 -------
Попробуйте 20020927-alt4.1