Bug 9743 - не поддерживается php5
: не поддерживается php5
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/phpMyAdmin)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 9199
  Show dependency tree
 
Reported: 2006-06-29 13:32 by
Modified: 2006-12-22 01:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-29 13:32:29
Текущая сборка жестко связана по зависимостях с php4. Было бы хорошо, если бы
была независимость от версии php (4 и 5 поддерживаются в upstream). Нужно
как-то
привязаться к чему-то общему, что провайдят и php4 и php5. Текущая сборка
требует mod_php и php-mysql.
------- Comment #1 From 2006-06-29 13:36:59 -------
mod_php4 и mod_php5 провайдят php-engine. Можно к ним привязаться. Правда, php
cli тоже провайдит php-engine, поэтому не привязаться именно к mod_php. Может
попросить legion-а записать в provides mod_php* что-то специфичное именно для
mod_php? Хотя правильно все-таки привязываться именно к php-engine, наверное,
потому как apache может запускать php-скрипты на выполнение и не через mod_php.
------- Comment #2 From 2006-06-29 13:40:39 -------
(In reply to comment #1)
> mod_php4 и mod_php5 провайдят php-engine. Можно к ним привязаться.

Это не вопрос. В следующей сборке будет.
------- Comment #3 From 2006-06-29 14:00:27 -------
В общем, тут еще сложности с php-mysql и php5-mysql и т.д. Так что самое
простое, это сделать некий phpMyAdmin-www и два виртуальных пакета
phpMyAdmin-php4 и php5.
------- Comment #4 From 2006-06-29 14:14:30 -------
assign

буду думать и делать.
------- Comment #5 From 2006-08-09 14:41:57 -------
Уже сделал. Сейчас буду тестить.
------- Comment #6 From 2006-09-11 14:57:12 -------
Сделано. Сборка в Дедале alt3.
------- Comment #7 From 2006-11-30 21:56:57 -------
(In reply to comment #6)
> Сделано. Сборка в Дедале alt3.

Уже в Сизифе...