Bug 9765 - apt-get не получает и не устанавливает пакет php-base
: apt-get не получает и не устанавливает пакет php-base
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/php-base)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-07-10 21:18 by
Modified: 2006-07-14 00:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-07-10 21:18:52
субж

при обращении к http://www.sisyphus.ru/srpm/php-base получаем error [stats.pl:52]
через apt-get тоже, соответственно, получить не удаётся
------- Comment #1 From 2006-07-10 21:44:21 -------
Меняю компоненту на prometeus. Т.к. это проблемы в нём.

Согласно этому:

[icesik@iceberg ~]$ apt-cache show  php-base
Package: php-base
Section: Development/Other
Installed Size: 6108
Maintainer: Alexey Gladkov <legion@altlinux.ru>
Version: 2.1-alt1
Pre-Depends: rpmlib(PayloadFilesHavePrefix) (<= 4.0-1), 
rpmlib(CompressedFileNames) (<= 3.0.4-1)
Depends: control, coreutils, sh
Provides: php-base (= 2.1-alt1)
Architecture: noarch
Size: 4803
MD5Sum: 0635e697aafaceba9f3b042025850612
Filename: php-base-2.1-alt1.noarch.rpm
Description: Package with common data for various PHP packages
 The php-base package contains parts of PHP distribution which are in use
 by other PHP-related packages.


[icesik@iceberg ~]$


Его в репозитории больше нет.
------- Comment #2 From 2006-07-10 21:46:04 -------
Майк, обьясни куда у нас нынче модно ходить? :)

В смысле, где у нас актуальная версия prometeus (это-то что стоит на 
www.sisyphus.ru).
------- Comment #3 From 2006-07-10 22:21:06 -------
так как его поставить ? мне нужен пакет php-gd2, он зависит от php-libs, а
php-libs не ставится без php-base !
куда деваться ?!
------- Comment #4 From 2006-07-10 23:27:22 -------
(In reply to comment #2)
> Майк, обьясни куда у нас нынче модно ходить? :)
> 
> В смысле, где у нас актуальная версия prometeus (это-то что стоит на 
> www.sisyphus.ru).
http://alt2.linux.kiev.ua
Тебе можно без двойки)

(In reply to comment #3)
> а php-libs не ставится без php-base !
Не верю.

Следующие дополнительные пакеты будут установлены:
  php-libs
Следующие НОВЫЕ пакеты будут установлены:
  php-gd2 php-libs
0 будет обновлено, 2 новых установлено, 0 пакетов будет удалено и 366 не будет 
обновлено.
Необходимо получить 664kB архивов.
После распаковки потребуется дополнительно 1642kB дискового пространства.
Продолжить? [Y/n]
'ftp://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/i586/RPMS.classic/
php-libs-4.4.3.cvs20060626-alt1.i586.rpm' php-libs_1%3a4.4.3.cvs20060626-
alt1_i586.rpm 570144 dc29c8a18a4aecbd2d20d19cddb90a0e
'ftp://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/i586/RPMS.classic/
php-gd2-4.4.3.cvs20060626-alt1.i586.rpm' php-gd2_1%3a4.4.3.cvs20060626-
alt1_i586.rpm 93562 a5f4aa2a88f640ccb0a1b37dbe47c0f9


Впрочем, у меня кэш где-то недельной (+/-) давности.
------- Comment #5 From 2006-07-11 11:12:15 -------
На всякий -- noarch в sources.list есть?

Вообще лучше не "субж", а вывод apt-get install приводить.

2 icesik: не "модно", а просто там удаётся поддерживать в рабочем виде.  И никто
окружение не ломает.
------- Comment #6 From 2006-07-11 13:38:13 -------
(In reply to comment #3)
> так как его поставить ? мне нужен пакет php-gd2, он зависит от php-libs, а
> php-libs не ставится без php-base !
> куда деваться ?!

читайте, читайте рассылки! 
Уже очень давно у нас noarch и i586 разделились на две разные архитектуры. Чуть
менее чем "очень давно" символические ссылки из noarch в i586 были удалены.
Поэтому для использования apt нужно указывать как минимум две платформы: noarch
и ещё что-нибудь.
------- Comment #7 From 2006-07-13 13:18:13 -------
prometeus ни при чём, btw.
------- Comment #8 From 2006-07-13 16:09:27 -------
(In reply to comment #7)
> prometeus ни при чём, btw.

А чья это работа?
------- Comment #9 From 2006-07-13 22:33:56 -------
(In reply to comment #8)
> А чья это работа?
Что?
------- Comment #10 From 2006-07-14 00:43:49 -------
1) работа -- prometeus, глюки -- хостинг-related
2) вот что получается, если лепить "субж" в багрепорт, а потом довешивать ещё
пару строк, не имеющих ни малейшего отношения, а потом придёт icesik@ и это всё
прочитает спросонья и повесит куда попало...