Bug 9806 - Добавить в provides qt = %version
: Добавить в provides qt = %version
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libqt4)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-07-24 13:59 by
Modified: 2007-09-20 02:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-07-24 13:59:46
Есть предложение добавить в provides: qt = %version 
для улучшения совместимости (skype)
------- Comment #1 From 2006-07-31 14:03:18 -------
Не имеет смысла.
т.к. завтра или вчера будет qt = %другая_version, а еще есть qt-4
------- Comment #2 From 2006-08-11 13:25:13 -------
Я очень рад что завтра будет другая qt, 
но я всё же хотел бы поставить Skype: 
rpm -Uvh skype-1.2.0.18-fc3.i586.rpm 
error: failed dependencies: 
        qt >= 3.2 is needed by skype-1.2.0.18-fc3 
------- Comment #3 From 2006-08-30 17:20:24 -------
(In reply to comment #2)
> Я очень рад что завтра будет другая qt, 
> но я всё же хотел бы поставить Skype: 
> rpm -Uvh skype-1.2.0.18-fc3.i586.rpm 
Либо поставьте skype-1.2.0.18-alt1.i586.rpm, либо соберите пустой пакет, 
предоставляющий нужную вам зависимость.
Я ломать свои пакеты не хочу.

> error: failed dependencies: 
>         qt >= 3.2 is needed by skype-1.2.0.18-fc3 
Вы хотите, чтобы установилась qt4 ?
------- Comment #4 From 2006-09-01 23:18:56 -------
(In reply to comment #3)
> (In reply to comment #2)
> > Я очень рад что завтра будет другая qt, 
> > но я всё же хотел бы поставить Skype: 
> > rpm -Uvh skype-1.2.0.18-fc3.i586.rpm 
> Либо поставьте skype-1.2.0.18-alt1.i586.rpm, либо соберите пустой пакет, 
А где такой взять? Я наверное не понимаю чего-то, но даже RPMS.nonfree найти 
не могу.
> предоставляющий нужную вам зависимость.
Возможно в таких случаях есть смысл делать нечто типа skype-compat, подобно 
тому как делают для oracle.

> Я ломать свои пакеты не хочу.
Тоже разумно.
 
> > error: failed dependencies: 
> >         qt >= 3.2 is needed by skype-1.2.0.18-fc3 
> Вы хотите, чтобы установилась qt4 ?
мне всё равно
------- Comment #5 From 2006-09-04 10:53:29 -------
(In reply to comment #4)
> > Либо поставьте skype-1.2.0.18-alt1.i586.rpm, либо соберите пустой пакет, 
> А где такой взять? Я наверное не понимаю чего-то, но даже RPMS.nonfree найти 
> не могу.

Обсуждение этого было давно:

http://lists.altlinux.org/pipermail/sisyphus/2005-April/058351.html
------- Comment #6 From 2006-09-04 16:59:34 -------
(In reply to comment #5)
> > > Либо поставьте skype-1.2.0.18-alt1.i586.rpm, либо соберите пустой пакет, 
> > А где такой взять?
Собрать

[...]
> http://lists.altlinux.org/pipermail/sisyphus/2005-April/058351.html
Там про MDK-шный говориться, что совместим. На сколько - не знаю, но этой 
дурацкой зависимости там наверняка нет.

------- Comment #7 From 2007-06-18 21:25:28 -------
Может быть вы согласитесь добавить Provides: qt4-x11 ?

$ rpmU skype-1.4.0.74.rpm
error: failed dependencies:
        qt4-x11 >= 4.2 is needed by skype-1.4.0.74-fc5
------- Comment #8 From 2007-06-19 15:00:40 -------
(In reply to comment #7)
> Может быть вы согласитесь добавить Provides: qt4-x11 ?
Это совсем другое дело
------- Comment #9 From 2007-06-19 16:34:02 -------
qt4-4.3.0-alt2
------- Comment #10 From 2007-06-19 23:59:28 -------
Большое спасибо!
------- Comment #11 From 2007-09-03 10:35:57 -------
Увы, не обнаружил обещанную Provides:
$ rpm --provides libqt4-core
libQtCore.so.4
libQtCore.so.4(CXX3)
libqt4-core = 4.3.1-alt3
------- Comment #12 From 2007-09-03 18:38:36 -------
apt-cache show qt4-x11
------- Comment #13 From 2007-09-04 11:59:32 -------
А это правильно, что qt4 предоставляет qt4-x11? Ведь qt4 тянет за собой всякие 
libqt4-sql...
------- Comment #14 From 2007-09-04 15:55:24 -------
(In reply to comment #13)
> А это правильно, что qt4 предоставляет qt4-x11?
по идее да, более соответствует текущей раскладке по подпакетам.

> Ведь qt4 тянет за собой всякие libqt4-sql...
Да я понимаю, но эта зависимость на qt4-x11 сама по себе не согласуется с ALT.

Было бы правильнее взять тарбол c бинарями у них и запаковать в более ALT-овый 
пакет или подобрать более соответствующий из rpm-ов.