Bug 9938 - не работает shading/fading в urxvt (-sh и -fade)
: не работает shading/fading в urxvt (-sh и -fade)
Status: NEW
: Sisyphus
(All bugs in Sisyphus/rxvt-unicode)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-08-30 13:54 by
Modified: 2010-08-24 00:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-08-30 13:54:34
к сожалению в рассылке так и не ответили.

в urxvt не работает (или работает не как ожидается?) shading. терминал запускаю 
следующим образом:
urxvt -tr -sh 90 -tint red -fade 80

затенения терминала не наблюдаю, в результате чего он сливается с фоном. то 
есть shading не работает.
при переключении на другое окно темнее становится шрифт, но никак не фон 
терминала.

при запуске с отрицательными значениями результат получаю такое же.
------- Comment #1 From 2006-08-30 20:34:17 -------
да, увидел. как доберусь - поправлю.

(до рассылок уже добрался, но нужно время на разбор :) )
------- Comment #2 From 2006-09-13 01:30:52 -------
пол дела решилось: простое включение расширения composite разрешило проблему с 
shading'ом - в данный момент urxvt оттеняется по отношению к остальному фону. 
полной прозрачности я не включал.

параметр -fade все также продолжает затенять/осветлять шрифт, не трогая фон.
------- Comment #3 From 2008-04-22 15:03:40 -------
На текущего майнтейнера
------- Comment #4 From 2010-08-24 00:23:05 -------
Вот с такими настройками в ~/.Xdefaults всё вполне работает:

URxvt*shading:         75
URxvt*transparent:     true
URxvt*tintColor:       rgb:30/70/30

Видимо починено апстримом.
------- Comment #5 From 2010-08-24 00:42:43 -------
Вру, невнимательно прочитал.