Bug 9950 - шрифты Type1 не подключаются по умолчанию после установки
: шрифты Type1 не подключаются по умолчанию после установки
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/tetex-latex-tipa)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-09-02 22:51 by
Modified: 2008-06-13 12:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-09-02 22:51:23
При выполнении updmap в post-install скрипте пакета 
в действительности не используется файл tipa.map.

Чтобы он использовался, в пакет необходимо включать файл
/etc/tex-fonts.d/tipa.cfg такого содержания:
----tipa.cfg-------
Map tipa.map
----end tipa.cfg---

И выполнять updmap в post-install и post-uninstall  скриптах.

testcase:
hsh --initroot-only $TMPDIR
hsh-install $TMPDIR tetex-latex-tipa
hsh-shell $TMPDIR
fgrep tipa /etc/tex-fonts/*
<нет вывода -- нет шрифтов, ошибка>
------- Comment #1 From 2006-09-03 00:14:59 -------
Странно, как же оно работало-то у меня... Anyway, спасибо за такой багрепорт, в
котором содержится фикс. 1.3-alt3 в incoming.
Кстати, могу отдать пакет, он всё равно а) не развивается и б) мне не нужен.
------- Comment #2 From 2006-09-05 00:04:54 -------
> Странно, как же оно работало-то у меня... Anyway, спасибо за такой багрепорт, в
> котором содержится фикс. 1.3-alt3 в incoming.
> Кстати, могу отдать пакет, он всё равно а) не развивается и б) мне не нужен.

Думаю, пока нет необходимости отдавать, потому что ошибка эта закрыта 
очень быстро :) Посмотрю, что у меня будет с сизифовскими пакетами
осенью, может, возьму этот до кучи.