Bug 10099 - crashes with glibc-2.5
: crashes with glibc-2.5
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/pdnsd)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-07 23:44 by
Modified: 2007-01-08 12:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-07 23:44:26
pdnsd-1.2-alt1 неработоспособен после установки glibc-core-2.5-alt1 - при
попытке запуска падает со следующим выводом:

*** glibc detected *** /usr/sbin/pdnsd: munmap_chunk(): invalid pointer:
0x0806419c ***
======= Backtrace: =========
/lib/libc.so.6[0xb7eed619]
/usr/sbin/pdnsd[0x804a859]
/usr/sbin/pdnsd[0x804f275]
/usr/sbin/pdnsd[0x805a8c7]
/lib/libc.so.6(__libc_start_main+0xdc)[0xb7ea3174]
/usr/sbin/pdnsd[0x8049fd1]
======= Memory map: ========
08048000-08069000 r-xp 00000000 08:06 5668844    /usr/sbin/pdnsd
08069000-0806a000 rw-p 00020000 08:06 5668844    /usr/sbin/pdnsd
0806a000-0808c000 rw-p 0806a000 00:00 0          [heap]
b7e8c000-b7e8d000 rw-p b7e8c000 00:00 0 
b7e8d000-b7fa7000 r-xp 00000000 08:06 16846048   /lib/libc-2.5.so
b7fa7000-b7fa8000 r--p 0011a000 08:06 16846048   /lib/libc-2.5.so
b7fa8000-b7faa000 rw-p 0011b000 08:06 16846048   /lib/libc-2.5.so
b7faa000-b7fad000 rw-p b7faa000 00:00 0 
b7fad000-b7fbe000 r-xp 00000000 08:06 16844346   /lib/libpthread-2.5.so
b7fbe000-b7fc0000 rw-p 00011000 08:06 16844346   /lib/libpthread-2.5.so
b7fc0000-b7fc2000 rw-p b7fc0000 00:00 0 
b7fd3000-b7fdd000 r-xp 00000000 08:06 16846014   /lib/libgcc_s.so.1
b7fdd000-b7fde000 rw-p 00009000 08:06 16846014   /lib/libgcc_s.so.1
b7fde000-b7fe0000 rw-p b7fde000 00:00 0 
b7fe0000-b7ff7000 r-xp 00000000 08:06 16845867   /lib/ld-2.5.so
b7ff7000-b7ff9000 rw-p 00016000 08:06 16845867   /lib/ld-2.5.so
bfae1000-bfaf7000 rw-p bfae1000 00:00 0          [stack]
ffffe000-fffff000 ---p 00000000 00:00 0          [vdso]
------- Comment #1 From 2006-10-15 20:39:04 -------
*** Bug 10139 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2006-11-14 14:43:56 -------
ребилд из сизифа не помогает
зато собирается и работает
http://www.phys.uu.nl/~rombouts/pdnsd/releases/pdnsd-1.2.5-par.tar.gz

я использовал ./configure --build=i686-alt-linux --host=i686-alt-linux
--prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin
--sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include
--libdir=/usr/lib --libexecdir=/usr/lib --localstatedir=/var/lib
--sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info
--disable-dependency-tracking --without-included-gettext --with-default-id=pdnsd

glibc-2.5-alt3
------- Comment #3 From 2006-12-09 18:53:13 -------
ЙОП!!

Дело было в кривом патче alt-sock_path.
А также в идиотском макросе STRNDUP, пытающемся free() свой первый аргумент 
(который из-за этого патча указывал на сегмент данных). И как оно раньше 
работало...

2at: просьба отдать пакет.
------- Comment #4 From 2006-12-21 20:13:37 -------
1.2.5-alt1