Bug 10139 - pdnsd does not work with new glibc
: pdnsd does not work with new glibc
Status: CLOSED DUPLICATE of bug 10099
: Sisyphus
(All bugs in Sisyphus/pdnsd)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-15 14:33 by
Modified: 2006-12-21 20:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-15 14:33:27
PDNSD падает при запуске, выдавая симпатичный бектрейс:


Steps to Reproduce:
1.apt-get dist-upgrade
2.apt-get install pdnsd
3./sbin/service pdnsd start
Actual Results:  
 *** glibc detected *** /usr/sbin/pdnsd: munmap_chunk(): inval
id pointer: 0x0806419c ***
======= Backtrace: =========
/lib/libc.so.6[0xb7ebd159]
/usr/sbin/pdnsd[0x804a859]
/usr/sbin/pdnsd[0x804f275]
/usr/sbin/pdnsd[0x805a8c7]
/lib/libc.so.6(__libc_start_main+0xdc)[0xb7e73174]
/usr/sbin/pdnsd[0x8049fd1]
======= Memory map: ========
08048000-08069000 r-xp 00000000 08:03 106254     /usr/sbin/pdnsd
08069000-0806a000 rw-p 00020000 08:03 106254     /usr/sbin/pdnsd
0806a000-0808c000 rw-p 0806a000 00:00 0          [heap]
b7e31000-b7e3b000 r-xp 00000000 08:03 48678      /lib/libgcc_s.so.1
b7e3b000-b7e3c000 rw-p 00009000 08:03 48678      /lib/libgcc_s.so.1
b7e3c000-b7e5d000 rw-p b7e3c000 00:00 0 
b7e5d000-b7f76000 r-xp 00000000 08:03 100602     /lib/libc-2.5.so
b7f76000-b7f77000 r--p 00119000 08:03 100602     /lib/libc-2.5.so
b7f77000-b7f79000 rw-p 0011a000 08:03 100602     /lib/libc-2.5.so
b7f79000-b7f7c000 rw-p b7f79000 00:00 0 
b7f7c000-b7f8e000 r-xp 00000000 08:03 100609     /lib/libpthread-2.5.so
b7f8e000-b7f90000 rw-p 00011000 08:03 100609     /lib/libpthread-2.5.so
b7f90000-b7f93000 rw-p b7f90000 00:00 0 
b7fa8000-b7fbf000 r-xp 00000000 08:03 100599     /lib/ld-2.5.so
b7fbf000-b7fc1000 rw-p 00016000 08:03 100599     /lib/ld-2.5.so
bfda9000-bfdbf000 rw-p bfda9000 00:00 0          [stack]
ffffe000-fffff000 ---p 00000000 00:00 0          [vdso]


Expected Results:  
Starting pdnsd service: [DONE]
------- Comment #1 From 2006-10-15 20:38:57 -------

*** This bug has been marked as a duplicate of 10099 ***