Bug 11000 - Double-click does not work when expected (lists etc)
: Double-click does not work when expected (lists etc)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alterator-install2)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-03-03 10:01 by
Modified: 2008-04-16 14:51 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-03 10:01:30
Double-click does not work in the situations when it's expected, e.g. in the 
dialogs of form

---------------
| listitem1   |
| listitem2   |
| ....        |
---------------
|  [ OK ]     |
---------------

such as language selection dialog at the start of installer.
------- Comment #1 From 2007-03-03 21:24:01 -------
severity -> enh (интерфейсная доработка, не так уж важна)
------- Comment #2 From 2007-03-03 21:49:01 -------
Да, про то, как expected :)

В общем случае, конечно, никакого решения нет, нужно каждый диалог смотреть 
внимательно, но для случая "ListBox и кнопка OK" даблклик по item'у в ListBox 
должен приводить к выбору этого элемента и принятию выбора.
------- Comment #3 From 2007-03-08 18:42:11 -------
Reassigned to maintainer.
------- Comment #4 From 2007-03-09 18:12:15 -------
у listbox есть и return-pressed и double-clicked события
------- Comment #5 From 2007-11-10 15:23:45 -------
Эх, ещё бы пример где... вот в выбиралке языка или раскладки ;)
------- Comment #6 From 2008-03-24 14:20:45 -------
*** Bug 6630 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2008-04-16 14:51:01 -------
0.5-alt5