Bug 11310 - [4.0.2] default packages for profile
: [4.0.2] default packages for profile
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/spt-profiles-ovz)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
: 13000 14167
  Show dependency tree
 
Reported: 2007-04-02 11:53 by
Modified: 2008-01-30 23:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-02 11:53:14
Было бы неплохо:
- в создаваемые профили добавлять по умолчанию basesystem;
- также добавлять sysklogd или исправить такую вот проблемку:
subst: open: /etc/syslog.conf: No such file or directory
spt: Fatal failed to run cmd in chroot.
vecache: Fatal Cache altlinux-3.0 make failed.

А вообще -- замечательно!
------- Comment #1 From 2007-04-03 11:17:50 -------
(In reply to comment #0)
> Было бы неплохо:
> - в создаваемые профили добавлять по умолчанию basesystem;
это надо баги на соотвествующие виртуальные пакеты развешивать
------- Comment #2 From 2007-04-03 12:50:22 -------
Ты пальцем покажи, раз/перевешу :)

Здесь подразумевал изначальное состояние формы с пакетами.
------- Comment #3 From 2007-04-03 23:51:40 -------
Да, видимо в изначальную форму необходимо добавлять пакеты, без которых
контейнер жить не будет.

Список таковых можно получить, взяв все пакеты, которые входят во все
виртуальные пакеты ve-*

Т.е. - те пакеты, которые всегда присутствуют во всех ve-*
------- Comment #4 From 2007-04-03 23:53:26 -------
Ничего не понимаю - чем не устраивают существующие виртуальные пакеты?
------- Comment #5 From 2007-04-03 23:58:10 -------
А чем они могут устраивать ?

Их слишком мало, плюс всегда возникает необходимость сделать что-то отличающееся
от дефолтной поставки.

Например - собрать контейнер с apache, php и postgresql
------- Comment #6 From 2007-04-04 18:36:18 -------
(In reply to comment #4)
> Ничего не понимаю - чем не устраивают существующие виртуальные пакеты?
Неизвестностью.

Плюс плохо предоставлять ручки, которые при наиболее очевидном дёргании приводят
к нерабочему результату.  Я не пробовал создать template при полностью пустом
profile, но даже знание о том, как называется basesystem, не застраховало от
нужды в знании о sysklogd.

Здесь я предлагаю начальное содержание формы пакетов профиля, не более и не
менее.  Или это сложно?
------- Comment #7 From 2007-04-07 04:17:07 -------
2mike: ты хочешь пакет vesystem? ;)
------- Comment #8 From 2007-04-07 04:22:29 -------
Пакеты ve* неудобны тем, что их тяжело модифицировать через WEB интерфейс.

В этом случае было бы оптимально заполнять список дефолтными пакетами, с
возможностью удаления естественно.

Кстати, может быть при модификации контейнера показывать не пакет ve-*, а то,
от
чего он зависит ?
------- Comment #9 From 2007-04-07 17:06:47 -------
(In reply to comment #7)
> 2mike: ты хочешь пакет vesystem? ;)
Нет, я хочу, чтобы:
- после нажатия кнопки "построить" _собирался_ хотя бы минимально _рабочий_ образ;
- для этого не требовалась хвалёная альтовская непрямая телепатия по именам пакетов.

Сейчас требуется минимум basesystem sysklogd, чтобы собралось и заработало.

Вроде бы немного букв, но знать надо...
------- Comment #10 From 2007-04-07 23:34:09 -------
bug 11270 не оно?
------- Comment #11 From 2007-04-29 17:30:37 -------
(In reply to comment #10)
> bug 11270 не оно?
Нет, конечно.
------- Comment #12 From 2007-06-04 17:00:51 -------
Костик, люди уже спотыкаться начали.

Добавь в стартовые пакеты basesystem sysklogd, без них не собирается.
------- Comment #13 From 2007-06-20 23:15:43 -------
Жаль, что в коробку уже не попало.  По обсуждённому на LVEE -- поправишь?
(начальное содержание списка пакетов := basesystem sysklogd)
------- Comment #14 From 2007-11-05 16:18:29 -------
Ещё пришлось добавить 
- apt
- apt-conf-server
Без них ругалось на:
/etc/apt/sources.list: No such file or directory
------- Comment #15 From 2008-01-26 12:25:03 -------
Дим, это тривиально исправляемая ошибка (надо аж инициализировать список
пакетов
указанными) -- и люди об неё действительно спотыкаются.  Если Костик не
доберётся -- давай я поправлю.

А то непонятен смысл заявления "средства управления контейнерами", если для
того, чтоб воспользоваться одной из основных функций -- надо знать о структуре
графа зависимостей в ALT Linux заметно больше среднего майнтейнера, пожалуй.

Нам следует всячески избегать таких досадных мелочей, чтоб за ALT в новом
поколении не закрепилась всё та же слава "дистра для замороченных".  Например,
однобайтовая ошибка #833 стоила нам с misha@ в 2002 торможения начавшегося было
общения с одним из киевских бизнес-партнёров IBM (заводили их софт на
Junior/NetVista).
------- Comment #16 From 2008-01-26 13:42:49 -------
(In reply to comment #15)
> Дим, это тривиально исправляемая ошибка (надо аж инициализировать список пакетов
> указанными) -- и люди об неё действительно спотыкаются.  Если Костик не
> доберётся -- давай я поправлю.

Костик не доберётся, иначе бы уже добрался.
Так что если ты знаешь как исправить, то не жди.
------- Comment #17 From 2008-01-29 00:28:18 -------
Хорошо; тогда просьба выдать ACL на spt-profiles-ovz.

Добавляю в (бывший пустым) profiles/.default/ovz/packages:
alterator-control
alterator-fbi
alterator-sysinfo
alterator-users
apt
apt-conf-server
basesystem
interactivesystem
etcnet
openssh-server
passwd
sysklogd

по мотивам этой баги и зависимостей (несколько чрезмерных для VE) пакета ve-base:

$ rpm -qRp ve-base-0.1-alt5.noarch.rpm
interactivesystem                                                              
openssh-server  
etcnet  
glibc  
sysklogd  
netlist  
httpd-alterator  
alterator-fbi  
alterator-nut  
alterator-users  
alterator-net-tcp  
alterator-net-general  
alterator-control  
alterator-alternatives  
alterator-ovz  
alterator-sysinfo  
elinks  
strace  
passwd  
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

2 ldv: похоже, да -- я хочу vesystem :)  Состав выше сейчас проверить неудобно,
завтра постараюсь на стенд засунуть server-x86_64-20070810.iso да проверить.
------- Comment #18 From 2008-01-29 01:07:40 -------
(In reply to comment #17)
> Хорошо; тогда просьба выдать ACL на spt-profiles-ovz.

Выдал.

> Добавляю в (бывший пустым) profiles/.default/ovz/packages:
> interactivesystem

А какую роль играет этот файл?

------- Comment #19 From 2008-01-29 01:18:35 -------
> > Добавляю в (бывший пустым) profiles/.default/ovz/packages:
> А какую роль играет этот файл?
Дефолтный список пакетов, см. alterator-ovz/backend3/ovz-profile::alt_new()

Проверил, работает.  Но устанавливается glibc-locales при %_install_langs all в
/etc/rpm/macros => 40/146M тарбол/VE.

glibc-locales-virtual <- console-data <-[PreDep] console-common-scripts <-
interactivesystem

Оставлю-ка старую добрую basesystem... это 22/65M :)

Created commit 4e30d73: 0.2.1-alt1
------- Comment #20 From 2008-01-29 15:24:50 -------
Надо бы добавить sudo/su и возможность управления пакетной базой... только вот
первое заведомо недостаточно само по себе, а второе сейчас реализуемо только
путём создания более другого профиля->темплейта.

Ладно, всё равно отдельно думать.

* Tue Jan 29 2008 Michael Shigorin <mike@altlinux> 0.2.2-alt1
- oops, 0.2.1-alt1 was based on lakostis' 0.2-alt1 git repo
  while Sisyphus package was built from inger's 0.2-alt4
  => pulling changes upto 0.2-alt4

* Mon Jan 28 2008 Michael Shigorin <mike@altlinux> 0.2.1-alt1
- fix .default profile (#11310)
------- Comment #21 From 2008-01-30 18:38:30 -------
Нашлось в TODO:

passwd vim-console sudo openssh-clients
------- Comment #22 From 2008-01-30 22:16:14 -------
(In reply to comment #21)
> Нашлось в TODO:
> 
> passwd vim-console sudo openssh-clients

Майк, ты точно уверен, что тебе нужны все эти пакеты в _базовом_ профиле?
------- Comment #23 From 2008-01-30 23:45:08 -------
Я ж и не трогал уже базовый :)

Там просто как выходит: нет scp -- поди втяни что (если не засунуть или не
смонтировать сверху); нет passwd -- поди затолкай чего по ssh снаружи, если
ключики не под рукой...

Поэтому надо будет добавить помимо базового ещё "generic", но это отдельный FR.