Bug 11699 - Пакет содержит ненужные каталоги /usr/X11R6
: Пакет содержит ненужные каталоги /usr/X11R6
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/filesystem)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 11700 11701 11862
:
  Show dependency tree
 
Reported: 2007-05-05 20:29 by
Modified: 2011-09-15 04:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-05-05 20:29:12
# rpm -ql filesystem | grep X11R6
/usr/X11R6
/usr/X11R6/bin
/usr/X11R6/include
/usr/X11R6/lib
/usr/X11R6/lib/X11
/usr/X11R6/lib/tls
/usr/X11R6/man
/usr/X11R6/share
------- Comment #1 From 2007-05-10 20:45:17 -------
В 4.0 я бы оставил, а в Сизифе вполне можно эти старые каталоги убрать.
------- Comment #2 From 2007-05-22 00:57:57 -------
4. The /usr Hierarchy
    Purpose
    Requirements
    Specific Options
    /usr/X11R6 : X Window System, Version 11 Release 6 (optional)

optional -- это не "ненужный", а "необязательный".

Виталик, зачем торопиться с тем, что ещё лет пять будет по инерции
использоваться?  Оно тебе мешает?
------- Comment #3 From 2007-05-22 01:17:41 -------
Затем, что этот каталог по факту не нужен никаким пакетам в системе,
и я постараюсь сделать так, чтобы всякий мусор у меня в системе не
валялся, и уж тем более никто не пытался туда класть файлы.
Следующим шагом будет предложение запретить класть файлы в каталог /usr/X11R6.
Их там никто не ждёт.
Причин использовать это ещё лет 5 по инерции не вижу.
------- Comment #4 From 2007-05-22 01:33:36 -------
(In reply to comment #2)
> 4. The /usr Hierarchy
>     Purpose
>     Requirements
>     Specific Options
>     /usr/X11R6 : X Window System, Version 11 Release 6 (optional)
> 
> optional -- это не "ненужный", а "необязательный".

X Window System, Version 11 Release 6 (optional) -- у нас этого уже нет. У нас
уже 7 релиз.
------- Comment #5 From 2007-05-22 01:34:31 -------
(In reply to comment #3)
> Затем, что этот каталог по факту не нужен никаким пакетам в системе,
> и я постараюсь сделать так, чтобы всякий мусор у меня в системе не
> валялся, и уж тем более никто не пытался туда класть файлы.
> Следующим шагом будет предложение запретить класть файлы в каталог /usr/X11R6.

Я тоже за это.

> Их там никто не ждёт.
> Причин использовать это ещё лет 5 по инерции не вижу.

------- Comment #6 From 2007-05-22 22:01:49 -------
Такая жуткая вражда к какому-то каталогу напоминает ситуацию с "а давайте
прыгнм
на последний xorg, пофиг, что у 80% пользователей -- fglrx и nvidia сломаются".

> Затем, что этот каталог по факту не нужен никаким пакетам в системе
Видимо, ты не используешь xli.  Я -- использую.  И не только его.

Даже если что-то не надо тебе, не повод тратить энергию на войну с ветряными
мельницами.  Вон лучше к Creating /mnt/{cdrom,floppy} докопайся тогда уже.  Или
к мусору в /lib/modules.
------- Comment #7 From 2007-05-23 00:43:26 -------
Ну положим, xli можно и перепаковать, если он кому-то нужен.
А вот остальные программы ты не перечисляешь, поэтому я не могу понять 
весомость твоих аргументов.
Я не вижу пользы в существовании каталогов, в которых ничего нет и не будет.
Так как называется fglrx, который у тебя в X11R6?
И я думаю можно уже перестать пользоваться xli, она нежива уже лет 6.

Вообще надоели всякие древние поделки в Сизифе, типа imlib, из-за которой KDE! 
зависит от gtk1
$ apti kdegraphics-kuickshow
The following NEW packages will be installed:
  gtk+ imlib kdegraphics-kuickshow
------- Comment #8 From 2009-10-06 18:57:31 -------
Для справки:

$ fgrep -h /usr/X11R6/ Sisyphus/*/base/contents_index |cut -f2 |sort -u
clips-X11
fglrx_glx
filesystem
videogen
wmaker-theme-anger
wmaker-theme-cosmic
wmaker-theme-cosmicdream
wmaker-theme-cryotribe
wmaker-theme-dark
wmaker-theme-feartech
wmaker-theme-freake
wmaker-theme-indreams
wmaker-theme-intrigue
wmaker-theme-largovday
wmaker-theme-leetwm
wmaker-theme-leetwm-blue
wmaker-theme-lichen
wmaker-theme-linux
wmaker-theme-midnight
wmaker-theme-mozilla
wmaker-theme-openstepbeta
wmaker-theme-vivaldi
wmaker-theme-wo
wmaker-theme-yesterdayidied
wmmenu
wmmon
wmtunlo
xauth
xfree86_xkb_xml
------- Comment #9 From 2011-09-15 02:37:32 -------
$ grep -h ^/usr/X11R6/ Sisyphus/*/base/contents_index |cut -f2 |sort -u
fglrx_glx
filesystem
wmaker-theme-anger
wmaker-theme-cosmic
wmaker-theme-cosmicdream
wmaker-theme-cryotribe
wmaker-theme-dark
wmaker-theme-feartech
wmaker-theme-freake
wmaker-theme-indreams
wmaker-theme-intrigue
wmaker-theme-largovday
wmaker-theme-leetwm
wmaker-theme-leetwm-blue
wmaker-theme-lichen
wmaker-theme-linux
wmaker-theme-midnight
wmaker-theme-mozilla
wmaker-theme-openstepbeta
wmaker-theme-vivaldi
wmaker-theme-wo
wmaker-theme-yesterdayidied
xauth
xfree86_xkb_xml

Пора обновлять check_fhs() в sisyphus_check?
------- Comment #10 From 2011-09-15 04:24:21 -------
filesystem-2.3.9-alt1 -> sisyphus:

* Thu Sep 15 2011 Dmitry V. Levin <ldv@altlinux> 2.3.9-alt1
- Removed /cgroup.
- Removed obsolete /usr/X11R6 (closes: #11699).
- Added /dev/pts to Provides (closes: #12020).