Bug 11882 - Проблемы с драйвером звука на nForce3, драйвер intel8x0
: Проблемы с драйвером звука на nForce3, драйвер intel8x0
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-smp)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-05-24 20:01 by
Modified: 2007-06-17 19:16 (History)


Attachments
Звук на nForce3, драйвер intel8x0, ядро 2.6.18-wks-smp -- dmesg (23.89 KB, text/plain)
2007-05-25 10:06, Roman Savochenko
no flags Details
Звук на nForce3, драйвер intel8x0, ядро 2.6.18-wks-smp -- lsmod (2.74 KB, text/plain)
2007-05-25 10:07, Roman Savochenko
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-05-24 20:01:31
Branch 4.0
Звук на nForce3, драйвер intel8x0, ядро 2.6.18-wks-smp и 2.6.18-std-smp: В 
принципе звук работает, но alsamixer выдаёт ошибку “function snd_ctl_open 
failed for default: No such device”, а kmix отображает урезанный набор 
настроек и многие подписаны знаками вопроса типа "?????????????".
Возможно там и более общие проблемы, поскольку Audacity устройства звукового 
ввода/вывода не находит (https://bugzilla.altlinux.org/show_bug.cgi?id=11880)
------- Comment #1 From 2007-05-24 20:55:00 -------
Покажите вывод dmesg, lsmod и cat /proc/asound/cards (dmesg и lsmod лучше
аттачем, но как text/plain - без gzip или bzip2, они не настолько большие).
------- Comment #2 From 2007-05-25 10:06:25 -------
Created an attachment (id=1994) [details]
Звук на nForce3, драйвер intel8x0, ядро 2.6.18-wks-smp -- dmesg
------- Comment #3 From 2007-05-25 10:07:39 -------
Created an attachment (id=1995) [details]
Звук на nForce3, драйвер intel8x0, ядро 2.6.18-wks-smp -- lsmod
------- Comment #4 From 2007-05-25 10:09:25 -------
Ну и:
[root@roman /]# cat /proc/asound/cards
--- no soundcards ---
------- Comment #5 From 2007-05-25 16:35:35 -------
Окстись, какой нафиг критикал.

У меня дома nf3, могу включить туда чего и тоже проверить.
------- Comment #6 From 2007-05-25 16:51:36 -------
Нужно удалить пакеты kernel-modules-oss-* - они предназначались для установки
только в случае неработоспособности драйверов ALSA, чтобы можно было проверить
работу с драйвером OSS. Либо можно добавить "blacklist i810_audio" в
/etc/modprobe.d/blacklist-local.
------- Comment #7 From 2007-05-25 18:05:22 -------
Может их тогда не ставить по умолчанию? Раньше ведь и не ставили.
------- Comment #8 From 2007-05-25 19:09:51 -------
А этот пакет установился по умолчанию? Если так - баг надо перевешивать на
инсталлер (вот только непонятно, на какой пакет - их там слишком много).
------- Comment #9 From 2007-05-25 21:58:51 -------
Да устанавливается. После удаления OSS модулей KMIX нормальные настройки 
показал и alsamixer запустился. Проблему с Audacity это не решило, наверное 
проблема с самой программой.
Багу перевешу.
------- Comment #10 From 2007-05-26 14:52:58 -------
Т.к. вопрос скорее десктопный, приглашаю Антона.
------- Comment #11 From 2007-06-17 19:16:12 -------
ALT4.0: 15.06.2007
Модули OSS уже не ставятся.