Bug 11939 - new version is required
: new version is required
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/perl-version)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 12505
  Show dependency tree
 
Reported: 2007-05-31 20:43 by
Modified: 2007-08-28 12:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-05-31 20:43:49
0.68 is required
------- Comment #1 From 2007-05-31 20:46:21 -------
могу NMU
------- Comment #2 From 2007-06-10 22:35:21 -------
Какому пакету он требуется?
Я бы не рекомендовал сейчас использовать version.pm в достаточно базовых или
важных пакетов, т.к. версионирование зависимостей в rpm-build-perl для таких
версий, скорее всего, работать не будет (или будет работать неправильно).

Я даже оторвал в пакете Class::DBI этот version.pm.

-use version; $VERSION = qv('3.0.15');
+$VERSION = v3.0.15;

Подробнее см. perl-Class-DBI.git 3.0.15-2-g99660f1
Впрочем, не то чтобы я предлагаю отрывать его везде.
------- Comment #3 From 2007-06-11 12:27:38 -------
я собирал SVK (SVN c branches)
 и Pushmi.
По моему, хотел SVK.

все лучше собрать, на всяк случай.
------- Comment #4 From 2007-07-22 14:22:45 -------
Мне нужен perl-version для сборки Module::Load::Conditional, который требуется 
для perl-CPANPLUS
------- Comment #5 From 2007-08-07 01:38:46 -------
У меня несколько пакетов использует Module::Load::Conditional, который 
использует perl-version.
Если есть основания советовать отрывать везде использование 
Module::Load::Conditional, внимаю совету. Если оснований нет, прошу собрать 
новую версию perl-version.
------- Comment #6 From 2007-08-10 21:47:15 -------
Собираю новую версию perl-version.
------- Comment #7 From 2007-08-26 13:40:02 -------
Собрано.