Bug 12964 - libapr-1.so should not be packaged into libapr1
: libapr-1.so should not be packaged into libapr1
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libapr1)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-09-29 15:00 by
Modified: 2009-04-09 23:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-09-29 15:00:02
В пакете libapr1 запакован симлинк libapr-1.so, который должен находиться
только
в пакете libapr1-devel.

pkgconfiglib.req:
/usr/src/tmp/aprutil1-buildroot/usr/lib/pkgconfig/apr-util-1.pc:
/usr/lib/libapr-1.so provided by: libapr1 libapr1-devel
pkgconfiglib.req:
/usr/src/tmp/aprutil1-buildroot/usr/lib/pkgconfig/apr-util-1.pc: libapr-1.so ->
/usr/lib/libapr-1.so (raw, ambiguous)

В очень редких случаях (для поддержки проприетарных бинариков) иногда пакуют
симлинк в lib%name пакет.  В этом случае нужно оставлять комментарий в
spec-файле по месту запаковки симлинка.
------- Comment #1 From 2007-09-30 14:22:32 -------
*** Bug 12989 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2009-03-17 22:08:29 -------
rpm -q libapr1
libapr1-1.3.3-alt1
rpm -ql libapr1
/usr/lib/libapr-1.so.0
/usr/lib/libapr-1.so.0.3.3
/usr/share/doc/libapr1-1.3.3
/usr/share/doc/libapr1-1.3.3/CHANGES
/usr/share/doc/libapr1-1.3.3/LICENSE
/usr/share/doc/libapr1-1.3.3/NOTICE