Bug 12989 - libapr-1.so should not be packaged into libapr1
: libapr-1.so should not be packaged into libapr1
Status: CLOSED DUPLICATE of bug 12964
: Sisyphus
(All bugs in Sisyphus/libapr1)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-09-30 14:15 by
Modified: 2007-09-30 14:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-09-30 14:15:31
В пакете libapr1 запакован симлинк libapr-1.so, который должен находиться
только
в пакете libapr1-devel.

pkgconfiglib.req:
/usr/src/tmp/aprutil1-buildroot/usr/lib/pkgconfig/apr-util-1.pc:
/usr/lib/libapr-1.so provided by: libapr1 libapr1-devel
pkgconfiglib.req:
/usr/src/tmp/aprutil1-buildroot/usr/lib/pkgconfig/apr-util-1.pc: libapr-1.so ->
/usr/lib/libapr-1.so (raw, ambiguous)

В очень редких случаях (для поддержки проприетарных бинариков) иногда пакуют
симлинк в lib%name пакет.  В этом случае нужно оставлять комментарий в
spec-файле по месту запаковки симлинка.
------- Comment #1 From 2007-09-30 14:22:31 -------

*** This bug has been marked as a duplicate of 12964 ***