Bug 13265 - Не проигрывает ogg файлы размером меньше 7900 bytes
: Не проигрывает ogg файлы размером меньше 7900 bytes
Status: CLOSED DUPLICATE of bug 13267
: Sisyphus
(All bugs in Sisyphus/gstreamer)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-31 10:08 by
Modified: 2007-10-31 10:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-31 10:08:06
gst-launch не проигрывает маленькие файлы, размером приблизительно до 7900
байт.
Проверял на ogg файлах из пакета gcompris-voices-ru.
$ rpm -qa | grep gst-plugins
libgst-plugins-0.10.14-alt1
gst-plugins-oss-0.10.6-alt1
gst-plugins-base-audio-filters-0.10.14-alt1
gst-plugins-alsa-0.10.14-alt1
gst-plugins-vorbis-0.10.14-alt1
gst-plugins-base-0.10.14-alt1
gst-plugins-ogg-0.10.14-alt1
gcompris-gst-plugins-8.4.2-alt1
gst-plugins-good-0.10.6-alt1

[slava@dubrhost ~]$ gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/quit.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 725567000 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...

Это играет

[slava@dubrhost ~]$ gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/plus.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

(gst-launch-0.10:21544): GStreamer-CRITICAL **: gst_event_new_new_segment_full:
assertion `start <= stop' failed
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 22239000 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...

Это нет.

Из под xmms все файлы звук издают.
Steps to Reproduce:
1. apt-get install gcompris-voices-ru gcompris-gst-plugins
2. gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/plus.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
3.
------- Comment #1 From 2007-10-31 10:16:04 -------
(In reply to comment #0)
> gst-launch не проигрывает маленькие файлы, размером приблизительно до 7900 байт.
> Проверял на ogg файлах из пакета gcompris-voices-ru.

Приложи какой-нибудь для теста.
------- Comment #2 From 2007-10-31 10:28:36 -------

*** This bug has been marked as a duplicate of 13267 ***