Bug 13386 - Странности с зависимостями
: Странности с зависимостями
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/yelp)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 9330
:
  Show dependency tree
 
Reported: 2007-11-11 15:58 by
Modified: 2008-01-07 18:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-11-11 15:58:15
yelp зачем-то зависит от gnome-doc-utils, при том, что
судя по зависимостям, gnome-doc-utils - это devel-пакет, нужный при сборке 
документации.

$ apti gnome-doc-utils
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libxml2 libxml2-devel python-module-libxml2 xml-utils zlib-devel
------- Comment #1 From 2007-11-11 16:05:37 -------
Сейчас уже не помню (зависимость действительно явным образом прописана в спеке)
- по-моему, в gnome-doc-utils входят ресурсы (.png какие-нибудь), которые yelp
использует для вёрстки страниц. Правильным было бы вынести эти ресурсы в
отдельный пакет, конечно. У меня на это появится время в лучшем случае в среду,
не раньше.
Ну и yelp 2.20 собрать надо, конечно.
------- Comment #2 From 2007-12-02 12:07:50 -------
Ну я очень надеюсь, что в месяц на решение проблемы с
error: removing these packages would break dependencies:
        pkgconfig(libxml-2.0)   is needed by gnome-doc-utils-0.12.0-alt1
мы таки уложимся :)

Comment #4 From Alexey Rusakov 2006-05-09 22:58  [reply] -------  
gnome-doc-utils нужен для создания на лету XML-представления, например, для 
man- и info-страничек и тоже является необходимой зависимостью.
------- Comment #3 From 2007-12-29 12:22:37 -------
Такое впечатление, что gnome-doc-utils действительно не нужен. По крайней мере,
yelp без gnome-doc-utils выглядит вполне рабочим. Проверяйте, yelp-2.21.1-alt2
отправился в /i/S.
------- Comment #4 From 2008-01-07 18:03:11 -------
Да, всё хорошо.