Bug 9330 - Too many requires
: Too many requires
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/yelp)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 13386
  Show dependency tree
 
Reported: 2006-03-28 12:56 by
Modified: 2007-12-29 12:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-28 12:56:35
Пытаюсь посмотреть на текущего Gnome2 в Сизифе, и непонятно, зачем нужны
libxml2-devel и mozilla:

apt> install yelp
Чтобы выполнить эту операцию необходимы изменения, которые не были запрошены.
Следующие НОВЫЕ пакеты будут установлены:
  gnome-doc-utils gnome-doc-utils-xslt libxml2-devel mozilla yelp

yelp-2.13.5-alt2.i586.rpm
------- Comment #1 From 2006-04-18 22:12:22 -------
$ rpm -e --test libxml2-devel
error: removing these packages would break dependencies:
        pkgconfig(libxml-2.0)   is needed by gnome-doc-utils-0.5.6-alt1
$
------- Comment #2 From 2006-04-18 22:13:50 -------
$ rpm -e --test mozilla
error: removing these packages would break dependencies:
        mozilla   is needed by yelp-2.14.1-alt1
        /usr/lib/mozilla/libgtkembedmoz.so   is needed by yelp-2.14.1-alt1
        /usr/lib/mozilla/libxpcom.so   is needed by yelp-2.14.1-alt1
$

Выходит что мозилла таки нужна.
------- Comment #3 From 2006-04-19 14:17:02 -------
Ну если gnome-doc-utils тоже нужен, тогда багу можно закрывать. В идеале нужно
научить yelp работать с общими для firefox и mozilla библиотеками.
------- Comment #4 From 2006-05-09 22:58:30 -------
Это невозможно. yelp использует движок Gecko для показа страничек, и как
следствие, должен собираться с одним из вариантов: либо Firefox, либо Mozilla.
gnome-doc-utils нужен для создания на лету XML-представления, например, для
man-
и info-страничек и тоже является необходимой зависимостью.