Bug 13396 - mod_perl crashed on otrs
: mod_perl crashed on otrs
Status: CLOSED FIXED
: Branch 4.0
(All bugs in Branch 4.0/apache2-mod_perl)
: 4.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-12 15:23 by
Modified: 2008-01-12 16:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-11-12 15:23:16
apache2 + mod_perl 2.0.3, собранный с последним perl-5.8.8-alt14, падает на
некоторых приложениях, конкретно otrs-2.2.4 (http://otrs.org)

см. багу https://bugzilla.altlinux.org/show_bug.cgi?id=13366

в случае с mod_perl выглядит так:

[Thu Nov  8 13:29:36 2007] -e: Attempt to free unreferenced scalar: SV
0xaab0ee8, Perl interpreter: 0x810cd60 at /opt/otrs//Kernel/System/Config.pm
line 1325. (таких строк много)
*** glibc detected *** /opt/otrs/bin/cg: munmap_chunk(): invalid pointer:
0x0ad462d0 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7e69402]
/usr/lib/libperl.so.5.8(Perl_safesysfree+0x21)[0xb79e6d01]
(еще много информации по backtrace)

стоит ли мне пересобирать mod_perl2, как в случае с perl для cgi?
------- Comment #1 From 2007-11-12 15:26:47 -------
да, "собранный с.." имеется ввиду тот, что по умолчанию в дистрибутиве собран.

apache2-mod_perl-doc-2.0.3-alt5 с тем, что по умолчанию perl-5.8.8-alt14
в случае с cgi  я собрал старую сборку perl ..alt5 из архива сизифа на начало
прошлого года, установил с --nodeps, и cgi заработал (не падает).
------- Comment #2 From 2007-11-12 17:13:31 -------
Что-то мне подсказывает, что mod_perl2 тут не причём. И от его пересборки 
работать оно не начнёт. OTRS не работает в принципе, см. 
https://bugzilla.altlinux.org/show_bug.cgi?id=12953

Я попробую развернуть у себя VPS c mod_perl2 + OTRS, может, что найду.
------- Comment #3 From 2007-11-12 21:06:46 -------
о, оказывается это не у меня одного проблема ;))
спасибо за ссылку на багу.
OTRS сам по себе прекрасно работает, если работает окружение (perl, libperl,
mod_perl и т.п.)

поясню что я делал: пытался найти вилку версий, между которыми было бы ясно,
где
сломалось. попробовав apache2 + mod_perl2 и получив вышеописанное, я перешел на
apache1 + CGI как вариант попроще и пробовал:
 - различные версии otrs  + perl-5.8.8-alt14 (2.2.4 нет, 2.1.3 нет, 2.0.5 да)
 - одинаковая версия otrs (2.2.4) + perl-5.8.8-alt5 вместо -alt14 (работает!)

т.е. проблема где-то между alt5 и alt14.
но как CGI оно, конечно, не устраивает, если авторы сами подчеркивают, что
писали в рассчете на mod_perl и скорость.

старый perl  собрал из src.rpm и установил с --nodeps (а то слишком много на
него завязано, полсистемы выносит ;).
теперь есть желание перейти на mod_perl. 
at@ на баги мою (см. выше, 13366) и vitty@ (что вы указали) реагировать что-то
не продолжил, поэтому я и обратился к вам. 

при попытке запустить apache2 + mod_perl2 из бранча4 и perl-base-5.8.8-alt5 
ругается, что mod_perl.so не нашел нужных символов в libperl.so, поэтому я и
предложил (себе) пересобрать и его ;)

но поскольку я предпочитаю все же более дистрибутивные подходы, чем "подточил в
своем темном углу, прибил кое-как и держится", то и пишу сюда.. с целью найти
общее решение. Ведь если валится на этом, потом завалится и на другом.
------- Comment #4 From 2007-12-06 10:26:31 -------
какие-нибудь новости?
------- Comment #5 From 2008-01-12 16:55:05 -------
новости такие:

бага пофикшена будет в следующем релизе софта в апстриме

http://bugs.otrs.org/show_bug.cgi?id=2491