Bug 13792 - service postgresql start FAILED
: service postgresql start FAILED
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/postgresql8.2-server)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-25 01:39 by
Modified: 2008-01-08 22:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-12-25 01:39:43
# apt-get install postgresql8.2-server
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  monit-base postgresql-common postgresql8.2
The following NEW packages will be installed:
  monit-base postgresql-common postgresql8.2 postgresql8.2-server
0 upgraded, 4 newly installed, 0 removed and 1 not upgraded.
Need to get 0B/6017kB of archives.
After unpacking 16.1MB of additional disk space will be used.
Do you want to continue? [Y/n]
Committing changes...
Preparing...                 
####################################################################################### 
[100%]
1: monit-base                
####################################################################################### 
[ 25%]
2: postgresql8.2             
####################################################################################### 
[ 50%]
3: postgresql8.2-server      
####################################################################################### 
[ 75%]
Done.
[root@carouselambra pgsql-root]# service postgresql start
Adjusting environment for postgresql:                                                                               
[FAILED]
------- Comment #1 From 2007-12-26 14:05:41 -------
(с голоса) "вылечилось установкой пакетов из бранча"

Насколько помню, mithraen@ упоминал проблемы в chrooted-скриптах, которые было
надо вообще вынести из этих пакетов в какой -common.
------- Comment #2 From 2007-12-26 16:23:33 -------
(In reply to comment #1)
> (с голоса) "вылечилось установкой пакетов из бранча"

У меня на сегодня с postgresql8.2-server проблем нет - ни в Сизифе, ни в 4.0.

> Насколько помню, mithraen@ упоминал проблемы в chrooted-скриптах, которые было
> надо вообще вынести из этих пакетов в какой -common.

Там проблема со всякими PL/Perl, PL/Tcl и т.п.
Только это уже ближе к #12055.
------- Comment #3 From 2007-12-26 16:41:22 -------
Точнее надо поставить postgresql8.2-contrib
------- Comment #4 From 2007-12-29 15:11:56 -------
8.2.5-alt4