Bug 14005 - Хорошо бы добавить autoremove к apt-get
: Хорошо бы добавить autoremove к apt-get
Status: NEW
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-15 06:32 by
Modified: 2016-04-30 23:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-15 06:32:54
Хорошо было бы, если бы и у нас в apt-get появилась опция autoremove.

Насколько я понял, такое есть, к примеру, в Ubuntu 7.04.
------- Comment #1 From 2008-01-16 11:45:22 -------
А что она делает? Где почитать? Чем хороша? Хотя бы линк какой привёл бы :)
------- Comment #2 From 2008-01-16 13:32:53 -------
Полагаю, google://autoremove :-)

Как я понял, оно печатает имена пакетов, которые установлены автоматически по
зависимостям, при установке/удалений пакетов. Может по запросу удалить такие пакеты.
------- Comment #3 From 2008-01-16 13:54:30 -------
Это умеет aptitude.  Только у него есть проблемы с обработкой Obsoletes.
------- Comment #4 From 2008-01-17 04:44:59 -------
(In reply to comment #3)
> Это умеет aptitude.  Только у него есть проблемы с обработкой Obsoletes.

Знаю. Но хочется именно apt. Тем более, что, вроде бы уже и код для этого есть.
------- Comment #5 From 2009-03-02 20:17:37 -------
*** Bug 19040 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2016-04-08 16:05:51 -------
Приходится переустанавливать систему, когда место заканчивается на системном
диске.
Ад матай, бrатья!?
------- Comment #7 From 2016-04-30 23:04:20 -------
Во чего нашел:
#apt-get install eepm
#epm autoremove

Только очень долго он работает.