Bug 1402 - apt-get install segfaults
: apt-get install segfaults
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P5 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-10-13 17:53 by
Modified: 2004-02-07 19:24 (History)


Attachments
0001402-base.tar.bz2 (4.92 KB, application/x-bzip2)
2002-10-13 17:53, Sergey Vlasov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-10-13 17:53:13
I have created the test repository:

.:
total 0
drwxr-xr-x    2 vsu      vsu            96 Oct 13 17:28 SRPMS.local
drwxr-xr-x    4 vsu      vsu           104 Oct 12 13:03 i586

./SRPMS.local:
total 917
-r--r--r--    1 vsu      vsu        934462 May 15 19:54 uw-imap-2001a-alt6.src.rpm

./i586:
total 0
drwxr-xr-x    2 vsu      vsu           152 Oct 13 17:28 RPMS.local
drwxr-xr-x    2 vsu      vsu           248 Oct 13 17:29 base

./i586/RPMS.local:
total 1830
-r--r--r--    1 vsu      vsu       1348167 May 15 19:54 uw-imap-2001a-alt6.i586.rpm
-r--r--r--    1 vsu      vsu        518808 May 15 19:54 uw-imap-devel-2001a-alt6.i586.rpm

./i586/base:
total 20
-rw-r--r--    1 vsu      vsu           328 Oct 13 17:29 hashfile
-rw-r--r--    1 vsu      vsu          3674 Oct 13 17:29 pkglist.local
-rw-r--r--    1 vsu      vsu          1510 Oct 13 17:29 pkglist.local.bz2
-rw-r--r--    1 vsu      vsu             0 Oct 13 17:29 release.local
-rw-r--r--    1 vsu      vsu          1213 Oct 13 17:29 srclist.local
-rw-r--r--    1 vsu      vsu           763 Oct 13 17:29 srclist.local.bz2

uw-imap*.rpm files are from ALT Linux Master 2.0 updates; base/* tarball is attached.

Contents of /etc/apt/sources.list:

rpm     file:/home/vsu/Archive/LocalPackages i586 local
rpm-src file:/home/vsu/Archive/LocalPackages i586 local

Initially the uw-imap package is not installed.

# apt-get install uw-imap
Processing File Dependencies... Done
Reading Package Lists... Done       
Building Dependency Tree... Done
Starting
Starting 2
Done
The following NEW packages will be installed:
  uw-imap 
0 packages upgraded, 1 newly installed, 0 to remove(replace) and 2 not upgraded.
Segmentation fault (core dumped)
/lib/libbz2.so.1
Reading symbols from /lib/libpopt.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/libpopt.so.0
Reading symbols from /usr/lib/libstdc++-libc6.2-2.so.3...done.
Loaded symbols for /usr/lib/libstdc++-libc6.2-2.so.3
Reading symbols from /usr/lib/debug/libm.so.6...done.
Loaded symbols for /usr/lib/debug/libm.so.6
Reading symbols from /usr/lib/debug/libc.so.6...done.
Loaded symbols for /usr/lib/debug/libc.so.6
Reading symbols from /lib/libdb-4.0.so...done.
Loaded symbols for /lib/libdb-4.0.so
Reading symbols from /usr/lib/libbeecrypt.so.2...done.
Loaded symbols for /usr/lib/libbeecrypt.so.2
Reading symbols from /usr/lib/debug/libpthread.so.0...done.

warning: Unable to set global thread event mask: generic error
[New Thread 1024 (LWP 9566)]
Error while reading shared library symbols:
Cannot enable thread event reporting for Thread 1024 (LWP 9566): generic error
Reading symbols from /usr/lib/debug/librt.so.1...done.
Loaded symbols for /usr/lib/debug/librt.so.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x2ad1e771 in strlen () from /usr/lib/debug/libc.so.6
(gdb) bt
#0  0x2ad1e771 in strlen () from /usr/lib/debug/libc.so.6
#1  0x2ab749f3 in rpmRecordParser::FileName () from /usr/lib/libapt-pkg.so.3.1
#2  0x2ab4742b in pkgAcqArchive::pkgAcqArchive ()
   from /usr/lib/libapt-pkg.so.3.1
#3  0x2ab2eb14 in pkgPackageManager::GetArchives ()
   from /usr/lib/libapt-pkg.so.3.1
#4  0x0804ffa1 in strcpy ()
#5  0x08058b32 in strcpy ()
#6  0x2ab03c14 in CommandLine::DispatchArg () from /usr/lib/libapt-pkg.so.3.1
#7  0x08060441 in strcpy ()
#8  0x2acb66e7 in __libc_start_main (main=0x8060140 <strcpy+83404>, argc=3, 
    ubp_av=0x7ffff9b4, init=0x804b21c <_init>, fini=0x8062710 <_fini>, 
    rtld_fini=0x2aab5f54 <_dl_fini>, stack_end=0x7ffff9ac)
    at ../sysdeps/generic/libc-start.c:129

This happens with apt-0.3.19cnc55-alt3 (ALT Linux Master 2.0) and with 0.3.19cnc55-alt7; did not try the newest version.
---

---

------- Comment #1 From 2002-12-23 13:47:39 -------
проявляется ли это новом apt?
------- Comment #2 From 2002-12-23 13:47:39 -------
проявляется ли это новом apt?
------- Comment #3 From 2004-01-16 21:03:19 -------
Unable to reproduce.