Bug 14068 - apt-cache иногда ругается на duplicated-пакеты
: apt-cache иногда ругается на duplicated-пакеты
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-17 22:59 by
Modified: 2011-01-20 09:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-17 22:59:22
При использовании apt ИНОГДА выскакивает предупреждение вот в таком виде:

apt-cache search <запрос>
....
....
.... список найденного
W: В Вашей системе установлено несколько версий пакета 
"kernel-image-wks-smp".

Этот пакет не может быть обновлён обычным путём до тех пор, пока Вы не
оставите только одну его версию. Чтобы оставить установленными несколько 
версий,
и не получать больше этого предупреждения, Вы можете установить 
следующий параметр
в Вашем файле конфигурации:

RPM::Allow-Duplicated { "^kernel-image-wks-smp$"; };

Чтоб


Вот именно так, заканчивая сиротливым словом "чтоб". Повторный запуск apt-cache
проходит БЕЗ ошибки. 

Конфиг вроде верный:
[alexei@threebears ~]$ grep -A 2 -B 2 kernel-image /etc/apt/*
/etc/apt/apt.conf-              "^gnupg$";
/etc/apt/apt.conf-              "^vim-common$";
/etc/apt/apt.conf:              "^kernel-image-wks-smp$";
/etc/apt/apt.conf-              "^kernel-modules-nvidia-wks-smp$";
/etc/apt/apt.conf-              ;
------- Comment #1 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #2 From 2011-01-20 00:14:14 -------
Воспроизводится?
Покажите вывод команды:

$ apt-config dump | grep -i dup

У меня:
RPM::Allow-Duplicated "";
RPM::Allow-Duplicated::
"^(NVIDIA_)?(kernel|alsa)[0-9]*(-adv|-linus)?($|-up|-smp|-secure|-custom|-enterprise|-BOOT|-tape|-aureal)";
RPM::Allow-Duplicated:: "^kernel-(image|modules)-.*";
------- Comment #3 From 2011-01-20 01:24:36 -------
(В ответ на комментарий №2)
> Воспроизводится?

Давно уже не видел этого. Наверное рассосалось.
------- Comment #4 From 2011-01-20 09:30:50 -------
Думаю можно закрывать