Bug 14603 - undefined symbol: gst_lfo_control_source_get_type
: undefined symbol: gst_lfo_control_source_get_type
Status: NEW
: Sisyphus
(All bugs in Sisyphus/python-module-gst)
: unstable
: all Linux
: P5 critical
Assigned To:
:
:
:
: 15079 15526
:
  Show dependency tree
 
Reported: 2008-02-21 16:25 by
Modified: 2011-01-22 17:44 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-21 16:25:27
python-module-gst-0.10.9-alt2.1

apt> depends python-module-gst
python-module-gst-0.10.9-alt2.1
  Depends: python = 2.5
    python-strict-2.5.1-alt1
    python-relaxed-2.5.1-alt1
  Depends: <libc.so.6(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt3
  Depends: <libc.so.6(GLIBC_2.1.3)>
    glibc-core-6:2.5.1-alt3
  Depends: <libc.so.6(GLIBC_2.4)>
    glibc-core-6:2.5.1-alt3
  Depends: <libglib-2.0.so.0>
    glib2-2.14.5-alt1
  Depends: <libgobject-2.0.so.0>
    glib2-2.14.5-alt1
  Depends: <libgstbase-0.10.so.0>
    libgstreamer-0.10.17-alt1
  Depends: <libgstcontroller-0.10.so.0>
    libgstreamer-0.10.17-alt1
  Depends: <libgstdataprotocol-0.10.so.0>
    libgstreamer-0.10.17-alt1
  Depends: <libgstinterfaces-0.10.so.0>
    libgst-plugins-0.10.17-alt1
  Depends: <libgstnet-0.10.so.0>
    libgstreamer-0.10.17-alt1
  Depends: <libgstreamer-0.10.so.0>
    libgstreamer-0.10.17-alt1
  Depends: <libpython2.5.so.1.0>
    python-base-2.5.1-alt1
  Depends: <python2.5(gobject)>
    python-module-pygobject-2.14.0-alt1.1
  Depends: <python2.5(gtk)>
    python-module-pygtk-2.12.0-alt2.1
  Depends: <python2.5(math)>
    python-modules-2.5.1-alt1
  Depends: <python2.5(os)>
    python-base-2.5.1-alt1
  Depends: <python2.5(pango)>
    python-module-pygtk-2.12.0-alt2.1
  Depends: <python2.5(pickle)>
    python-modules-2.5.1-alt1
  Depends: <python2.5(pygtk)>
    python-module-pygobject-2.14.0-alt1.1
  Depends: <python2.5(random)>
    python-modules-2.5.1-alt1
  Depends: <python2.5(time)>
    python-base-2.5.1-alt1
  Depends: <python2.5(warnings)>
    python-base-2.5.1-alt1
  Depends: <rtld(GNU_HASH)>
    glibc-core-6:2.5.1-alt3
apt> 

Steps to Reproduce:
$ quodlibet 
python: symbol lookup error:
/usr/lib/python2.5/site-packages/gst-0.10/gst/_gst.so: undefined symbol:
gst_lfo_control_source_get_type
$
------- Comment #1 From 2008-03-25 19:46:57 -------
The reason must be that the new python-module-gst-0.10.9-alt2.1 requires a newer
version of libgstreamer (or a related package), but I have an older package
installed and python-module-gst doesn't have an explicit dependency on the new
libgstreamer.

If this is so, please add the dependency to python-module-gst in order to enable
the use of `apt-get install'.

apt> showpkg libgstreamer 
Package: libgstreamer
Versions: 
0.10.18-alt1(/var/lib/apt/lists/ftp.altlinux.org_pub_distributions_ALTLinux_Sisyphus_i586_base_pkglist.classic)(/var/lib/apt/lists/ftp.linux.kiev.ua_pub_Linux_ALT_Sisyphus_i586_base_pkglist.classic)
0.10.14-alt1(/var/lib/rpm/Packages)

------- Comment #2 From 2008-03-25 19:55:58 -------
This inspired a general (but not realizable?) feature request:
https://bugzilla.altlinux.org/show_bug.cgi?id=15079 .
------- Comment #3 From 2008-04-04 05:13:45 -------
(In reply to comment #0)
> Steps to Reproduce:
> $ quodlibet 
> python: symbol lookup error:
> /usr/lib/python2.5/site-packages/gst-0.10/gst/_gst.so: undefined symbol:
> gst_lfo_control_source_get_type
> $

I just send python-module-gst-0.10.10-alt1.src.rpm for building. Fresh version
doesn't have this bug.

Feel free to reopen this issue if fresh version doesn't work.
------- Comment #4 From 2008-05-02 03:09:48 -------
python-module-gst-0.10.10-alt1 hasn't fixed the problem: the problem won't get
fixed by just rebuilding (rebuilding with updated source).

$ rhythmbox
rhythmbox: symbol lookup error:
/usr/lib/python2.5/site-packages/gst-0.10/gst/_gst.so: undefined symbol:
gst_lfo_control_source_get_type
$ 

What would fix the problem is making the package somehow require a recent
version of the library (libgstreamer or libgst-plugins, I guess); then "apt-get
install" would also update the library as required.

Probably, the more reasonable way to achieve this is not to add the dependency
by hand, but to (magic words) "версионировать библиотеку" (add the version to
the ABI) and rebuild this module then. (Cf.
https://bugzilla.altlinux.org/show_bug.cgi?id=15520#c5 .)
------- Comment #5 From 2008-05-18 03:47:22 -------
Well, so if the more delicate solution
https://bugzilla.altlinux.org/show_bug.cgi?id=15526 is not going to be there,
then perhaps the more brute solution should be made: add 

Requires: libgstreamer >= SVR-with-which-it-is-built-now

to python-module-gst.
------- Comment #6 From 2011-01-22 17:44:45 -------
Should be fixed by now, is it?