Bug 15066 - SEGFAULT при загрузке документов в формате MS Word Document 8
: SEGFAULT при загрузке документов в формате MS Word Document 8
Status: CLOSED DUPLICATE of bug 14801
: Sisyphus
(All bugs in Sisyphus/openoffice.org)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
: relnote
:
:
  Show dependency tree
 
Reported: 2008-03-25 00:11 by
Modified: 2008-03-25 22:28 (History)


Attachments
oowriter.dump.KOI8-R.bz2 (236.30 KB, application/octet-stream)
2008-03-25 00:12, Konstantin A Lepikhov (L.A. Kostis)
no flags Details
oowriter.dump.UTF-8.bz2 (219.85 KB, application/octet-stream)
2008-03-25 00:13, Konstantin A Lepikhov (L.A. Kostis)
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-25 00:11:54
[lakostis@lks ~]$ rpm -qa|fgrep openoffice
openoffice.org-2.4.0.2-alt1
openoffice.org-langpack-ru-2.4.0.2-alt1
[lakostis@lks ~]$ locale
LANG=ru_RU.KOI8-R
LC_CTYPE="ru_RU.KOI8-R"
LC_NUMERIC="ru_RU.KOI8-R"
LC_TIME="ru_RU.KOI8-R"
LC_COLLATE="ru_RU.KOI8-R"
LC_MONETARY="ru_RU.KOI8-R"
LC_MESSAGES="ru_RU.KOI8-R"
LC_PAPER="ru_RU.KOI8-R"
LC_NAME="ru_RU.KOI8-R"
LC_ADDRESS="ru_RU.KOI8-R"
LC_TELEPHONE="ru_RU.KOI8-R"
LC_MEASUREMENT="ru_RU.KOI8-R"
LC_IDENTIFICATION="ru_RU.KOI8-R"
LC_ALL=

вывод strace -Ff в аттаче. Ничего не меняется, если использовать
LC_ALL=ru_RU.UTF8 перед запуском oowriter. Документ к сожалению приложить не
могу, поскольку он содержит важную информацию, но подозреваю, что такое же
поведение происходит и с любым документом данного формата.

Steps to Reproduce:
1. oowriter <some document>.doc
2. ...
3. crash!boom!bang!
Actual Results:  
application crashed.

Expected Results:  
некое подобие приложения для редактирования документов.
------- Comment #1 From 2008-03-25 00:12:31 -------
Created an attachment (id=2514) [details]
oowriter.dump.KOI8-R.bz2
------- Comment #2 From 2008-03-25 00:13:02 -------
Created an attachment (id=2515) [details]
oowriter.dump.UTF-8.bz2
------- Comment #3 From 2008-03-25 15:28:58 -------

*** This bug has been marked as a duplicate of 14801 ***