Bug 14801 - spellchecker makes OO.o crash on this DOC
: spellchecker makes OO.o crash on this DOC
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/openoffice.org)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-07 04:00 by
Modified: 2008-03-31 21:47 (History)


Attachments
materials2.doc (373.50 KB, application/msword)
2008-03-07 04:01, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-07 04:00:20
openoffice.org-2.3.1.1-alt6

materials2.doc will be attached.

Steps to Reproduce:
$ ooffice materials2.doc
Actual Results:  
message window: "Due to an unexpected error, OpenOffice.org crashed. ... The
following files will be recovered: materials2"
------- Comment #1 From 2008-03-07 04:01:23 -------
Created an attachment (id=2480) [details]
materials2.doc

(c)V.I.Belikov
------- Comment #2 From 2008-03-07 04:03:12 -------
koffice-kword-1.6.3-alt10.1 opens this file (although it looks not very
pretty).
------- Comment #3 From 2008-03-07 04:05:02 -------
abiword-2.5.2-alt2 also opens this file.
------- Comment #4 From 2008-03-07 12:40:43 -------
openoffice.org-2.3.1-alt0.M40.2 opens this file without problem.
------- Comment #5 From 2008-03-07 14:26:00 -------
У меня на таком не падает:
[icesik@icesik ~]$ rpm -qa | grep openoffice
openoffice.org-gnome-2.3.1.1-alt6
openoffice.org-2.3.1.1-alt6
[icesik@icesik ~]$
------- Comment #6 From 2008-03-07 17:22:03 -------
выпадает где то на проверке орфографии. как вариант, отключить автоматическую 
проверку орфографии
------- Comment #7 From 2008-03-07 18:19:45 -------
(In reply to comment #6)
> выпадает где то на проверке орфографии. как вариант, отключить автоматическую 
> проверку орфографии

Да, подтверждаю. После того, как отключил (долго искал в меню, как, а оказалось,
это кнопка), не падает. При попытке проверить орфографию падает.

Но ошибка-то есть, так что баг оставляю открытым.
------- Comment #8 From 2008-03-23 21:21:21 -------
*** Bug 15000 has been marked as a duplicate of this bug. ***
------- Comment #9 From 2008-03-25 15:28:58 -------
*** Bug 15066 has been marked as a duplicate of this bug. ***
------- Comment #10 From 2008-03-25 22:28:13 -------
Мне помогло удаление hunspell-ru-io
------- Comment #11 From 2008-03-25 22:41:05 -------
Удаление hunspell конечно помогает, но это не выход. Например, у меня есть
только hunspell-ru, и oowriter продолжает падать.
------- Comment #12 From 2008-03-25 22:46:47 -------
У меня, например, нет hunspell-ru-io, зато:
$ rpm -qa '*hunspell*'
hunspell-de-20051111-alt1
hunspell-ru-20040406-alt1
libhunspell-1.2.1-alt1
hunspell-1.2.1-alt1
hunspell-fr-20060915-alt1
hunspell-en-20060207-alt1
hunspell-uk-20051106-alt1
$ 

Мне помогло отключение автопроверки и неиспользование проверки.
------- Comment #13 From 2008-03-27 16:43:56 -------
openoffice.org-2.4.0.4-alt1
------- Comment #14 From 2008-03-31 21:47:28 -------
Thanks! openoffice.org-2.4.0.5-alt1 works OK.