Bug 16134 - Невозможность запуска Enlightenment (run level 5)
: Невозможность запуска Enlightenment (run level 5)
Status: CLOSED WONTFIX
: Branch 4.1
(All bugs in Branch 4.1/enlightenment)
: unspecified
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-22 03:06 by
Modified: 2014-11-05 20:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-06-22 03:06:19
Во-первых, как  писал в community@, Enlightenment 16 зависит от пакетов E17.
Во-вторых, они оба попадают в меню wmselect в виде двух кнопок - Enlightenment
и E-17. Естественно, хочу запустить Enlightenment. Повлется окно типа xmessage,
где есть следующий текст:

Enlightenment Error

You are executing directly. This is bad. Please do not run the "enlightenment"
binary. Use the "enlightenment_start" launcher...

И т.д. 

Внизу окна этого сообщени две кнопки: F1 (Recovery) и F2 (Exit)

Неправильно прописывается запуск Enlightenment в wmselect, а именно в
/etc/X11/wmsession.d/05Enlightenment

[vova@book wmsession.d]$ ls
04IceWM  05E-17  05Enlightenment  15ede
[vova@book wmsession.d]$ cat 05Enlightenment
NAME=Enlightenment
ICON=/usr/share/icons/Enlightenment.xpm
EXEC=/usr/bin/startenlightenment
DESC=The enlightenment window manager
SCRIPT:
exec /usr/bin/startenlightenment

Либо в скрипте startenlightenment ошибка...  Судя по рекомендациям того
сообщения так оно и есть:

[vova@book wmsession.d]$ cat /usr/bin/startenlightenment
#!/bin/sh

/usr/bin/xsetroot -cursor_name watch
exec /usr/bin/enlightenment "$@"
/usr/bin/xsetroot -cursor_name X_cursor
------- Comment #1 From 2008-08-05 12:23:15 -------
Я вижу, что всем как-то не до этого... Nobody... Мда..
------- Comment #2 From 2009-01-10 17:08:37 -------
Еще актуально?
Скрипт startenlightenment чуть поменян.
Сборка на попробовать тут
ftp://ftp.altlinux.ru/pub/people/jinn/4.1/repo/i586/RPMS.hasher/enlightenment-0.16.8.9-alt1.M41.1.i586.rpm
------- Comment #3 From 2009-01-24 04:36:26 -------
(В ответ на комментарий №2)
> Еще актуально?
> Скрипт startenlightenment чуть поменян.
> Сборка на попробовать тут
> ftp://ftp.altlinux.ru/pub/people/jinn/4.1/repo/i586/RPMS.hasher/enlightenment-0.16.8.9-alt1.M41.1.i586.rpm

Спасибо. Я еще в прошлом году собрал вроде е16, положу-как хотя бы сюда, может
проверите и дальше двинете..
------- Comment #4 From 2009-01-30 11:02:58 -------
(В ответ на комментарий №3)
> (В ответ на комментарий №2)
> > Еще актуально?
> > Скрипт startenlightenment чуть поменян.
> > Сборка на попробовать тут
> > ftp://ftp.altlinux.ru/pub/people/jinn/4.1/repo/i586/RPMS.hasher/enlightenment-0.16.8.9-alt1.M41.1.i586.rpm
> 
> Спасибо. Я еще в прошлом году собрал вроде е16, положу-как хотя бы сюда, может
> проверите и дальше двинете..

Вот ссылки на src.rpm, которые я собирал для Branch 4.1:

http://narod.ru/disk/5334523000/e16keyedit-0.5-alt1.M41.src.rpm.html

http://narod.ru/disk/5334546000/e16-themes-0.16.8.0.2-alt1.M41.src.rpm.html

http://narod.ru/disk/5334558000/enlightenment-0.16.8.14-alt1.M41.src.rpm.html

http://narod.ru/disk/5334567000/epplets-0.11-alt1.M41.src.rpm.html

Проверьте, может уже стоит обновить версию на 0.16.8.14
------- Comment #5 From 2014-11-05 20:40:14 -------
В 4.1/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.