Bug 16435 - incomplete/imprecise dependencies
: incomplete/imprecise dependencies
Status: CLOSED DUPLICATE of bug 16334
: Sisyphus
(All bugs in Sisyphus/epiphany)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-25 22:52 by
Modified: 2008-12-08 23:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-07-25 22:52:42
epiphany-2.22.3-alt2

I upgraded epiphany from 2.22.1.1-alt1 to 2.22.3-alt2 with apt-get:

apt> install epiphany
Unrequested changes are needed to execute this operation.
The following packages will be upgraded
  epiphany
The following NEW packages will be installed:
  libavahi-gobject
1 upgraded, 1 newly installed, 0 removed and 0 kept.
Will need more 4506kB of archives.
After unpacking will need more 4682kB of disk space.
Do you want to continue? [Y/n] 
apt> 

Before this, epiphany-2.22.1.1-alt1 worked. Now epiphany-2.22.3-alt2 doesn't
start, probably, because of unsatisfied dependencies: 

$ epiphany

** (epiphany:7939): WARNING **: Could not find a suitable GRE!

and a message is displayed: "Epiphany can't be used now. Mozilla initialization
failed."



The versions of packages I have:

apt> depends epiphany
epiphany-2.22.3-alt2
  Depends: indexhtml
    indexhtml-sisyphus-1.3.2-alt1
    indexhtml-school_terminal-0.1.2-alt1
    indexhtml-school_master-0.1.2-alt1
    indexhtml-school_lite-0.1.2-alt1
    indexhtml-school_junior-0.1.2-alt1
    indexhtml-lite-4.0-alt2
    indexhtml-Desktop-1:4.0-alt8
  Depends: iso-codes
  PreDepends: desktop-file-utils
  PreDepends: </bin/sh>
    sh-3.2.39-alt1
  PreDepends: </bin/sh>
    sh-3.2.39-alt1
  PreDepends: </bin/sh>
    sh-3.2.39-alt1
  PreDepends: </usr/bin/update-desktop-database>
    desktop-file-utils-0.14-alt1
  PreDepends: </usr/sbin/gconf_install_schema>
    GConf-2.22.0-alt1
  PreDepends: </usr/sbin/gconf_uninstall_schema>
    GConf-2.22.0-alt1
  PreDepends: </usr/bin/update-desktop-database>
    desktop-file-utils-0.14-alt1
  Depends: </lib/ld-linux.so.2>
    glibc-core-6:2.5.1-alt5
  Depends: <libX11.so.6>
    libX11-3:1.1.4-alt6
  Depends: <libavahi-client.so.3>
    libavahi-0.6.22-alt6
  Depends: <libavahi-common.so.3>
    libavahi-0.6.22-alt6
  Depends: <libavahi-gobject.so.0>
    libavahi-gobject-0.6.22-alt6
  Depends: <libc.so.6(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.1)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.1.3)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.2)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.3)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.3.4)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.4)>
    glibc-core-6:2.5.1-alt5
  Depends: <libdbus-1.so.3>
    libdbus-1.2.1-alt2
  Depends: <libdbus-glib-1.so.2>
    libdbus-glib-0.76-alt1
  Depends: <libdl.so.2(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libdl.so.2(GLIBC_2.1)>
    glibc-core-6:2.5.1-alt5
  Depends: <libenchant.so.1>
    libenchant-1.3.0-alt0.1
  Depends: <libgcc_s.so.1(GCC_3.0)>
    libgcc4.1-4.1.2-alt3
    libgcc3.4-3.4.5-alt7
  Depends: <libgcc_s.so.1(GLIBC_2.0)>
    libgcc4.1-4.1.2-alt3
    libgcc3.4-3.4.5-alt7
  Depends: <libgconf-2.so.4>
    libGConf-2.22.0-alt1
  Depends: <libgdk-x11-2.0.so.0>
    libgtk+2-2.12.11-alt2
  Depends: <libgdk_pixbuf-2.0.so.0>
    libgtk+2-common-2.12.11-alt2
  Depends: <libgio-2.0.so.0>
    libgio-2.16.5-alt1
  Depends: <libglade-2.0.so.0>
    libglade-2.6.2-alt1
  Depends: <libglib-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.10)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.12)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.14)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.15.6)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.8)>
    glib2-2.16.5-alt1
  Depends: <libgmodule-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgnome-2.so.0>
    libgnome-2.22.0-alt3
  Depends: <libgnomeui-2.so.0>
    libgnomeui-2.22.1-alt2
  Depends: <libgobject-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgobject-2.0.so.0(GLIB_2.10)>
    glib2-2.16.5-alt1
  Depends: <libgobject-2.0.so.0(GLIB_2.12)>
    glib2-2.16.5-alt1
  Depends: <libgthread-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgtk-x11-2.0.so.0>
    libgtk+2-2.12.11-alt2
  Depends: <libgtk-x11-2.0.so.0(GTK_2.10)>
    libgtk+2-2.12.11-alt2
  Depends: <libgtk-x11-2.0.so.0(GTK_2.12)>
    libgtk+2-2.12.11-alt2
  Depends: <libgtk-x11-2.0.so.0(GTK_2.8)>
    libgtk+2-2.12.11-alt2
  Depends: <libm.so.6(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libnotify.so.1>
    libnotify-0.4.4-alt1
  Depends: <libnspr4.so>
    libnspr-1:4.7.2-alt1.20080628
  Depends: <libpango-1.0.so.0(PANGO_1.12)>
    libpango-1.20.5-alt1
  Depends: <libpthread.so.0(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libpython2.5.so.1.0>
    python-base-2.5.1-alt1
  Depends: <libstdc++.so.6(CXXABI_1.3)>
    libstdc++4.1-4.1.2-alt3
    libstdc++3.4-3.4.5-alt7
  Depends: <libstdc++.so.6(GLIBCXX_3.4)>
    libstdc++4.1-4.1.2-alt3
    libstdc++3.4-3.4.5-alt7
  Depends: <libxml2.so.2>
    libxml2-1:2.6.32-alt1
  Depends: <libxslt.so.1>
    libxslt-1.1.23-alt1
  Depends: <rtld(GNU_HASH)>
    glibc-core-6:2.5.1-alt5
apt>
------- Comment #1 From 2008-07-25 22:54:57 -------
In the bugreport, I described an attempt to run epiphany under a "clean" user.
When trying to run it under my usual user, the following messages are printed:


** (epiphany:7491): WARNING **: libgtkembedmoz.so: cannot open shared object
file: No such file or directory

** (epiphany:7491): WARNING **: Could not load extension file at
/usr/lib/epiphany/2.22/extensions/libpageinfoextension.so


** (epiphany:7491): WARNING **: libgtkembedmoz.so: cannot open shared object
file: No such file or directory

** (epiphany:7491): WARNING **: Could not load extension file at
/usr/lib/epiphany/2.22/extensions/libselectstylesheetextension.so


** (epiphany:7491): WARNING **: Could not find a suitable GRE!
------- Comment #2 From 2008-10-04 16:12:20 -------
в сизифе epiphany-2.23.91-alt1. всё работает.
------- Comment #3 From 2008-12-08 20:37:15 -------

*** This bug has been marked as a duplicate of bug 16334 ***