Bug 17077 - Ruby extension disabled: failed require 'gtk2'
: Ruby extension disabled: failed require 'gtk2'
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kazehakase)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 17425
:
  Show dependency tree
 
Reported: 2008-09-10 14:59 by
Modified: 2012-03-16 13:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-10 14:59:54
kazehakase-0.5.5-alt1

After I did "apt-get install kazehakase":

$ kazehakase 
kazehakase: symbol lookup error: /usr/lib/kazehakase/ext/ruby.so: undefined
symbol: rbg_cstr2rval
$ ldd -r /usr/lib/kazehakase/ext/ruby.so 
    linux-gate.so.1 =>  (0xb7f3e000)
    libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb7b25000)
    libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb7a90000)
    libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0xb7a57000)
    libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb798c000)
    libruby.so.1.8 => /usr/lib/libruby.so.1.8 (0xb78ae000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb7897000)
    libkazehakase.so.0 => /usr/lib/kazehakase/libkazehakase.so.0 (0xb77cc000)
    libc.so.6 => /lib/libc.so.6 (0xb76a4000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb768a000)
    libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb7681000)
    libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb7644000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xb755b000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7556000)
    libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb753c000)
    libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0xb7539000)
    libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb74d0000)
    libm.so.6 => /lib/libm.so.6 (0xb74a9000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb747f000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xb7471000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7469000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb7466000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xb745d000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7457000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb744e000)
    libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb744b000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb7448000)
    libdl.so.2 => /lib/libdl.so.2 (0xb7443000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7410000)
    /lib/ld-linux.so.2 (0x80000000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xb7408000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xb73f1000)
    libgnutls.so.13 => /usr/lib/libgnutls.so.13 (0xb7378000)
    libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb7326000)
    libz.so.1 => /lib/libz.so.1 (0xb7312000)
    libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb72eb000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7270000)
    libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb726e000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7256000)
    libdirectfb-1.1.so.0 => /usr/lib/libdirectfb-1.1.so.0 (0xb71e6000)
    libdirect-1.1.so.0 => /usr/lib/libdirect-1.1.so.0 (0xb71d5000)
    libglitz.so.1 => /usr/lib/libglitz.so.1 (0xb71af000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb718c000)
    libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb7163000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7142000)
    libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0xb7132000)
    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0xb712e000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xb712b000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7126000)
    libfusion-1.1.so.0 => /usr/lib/libfusion-1.1.so.0 (0xb711d000)
undefined symbol: rbgobj_define_class    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_instance_from_ruby_object   
(/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbg_rval2cstr_accept_nil    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_make_flags    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgtk_initialize_gtkobject   
(/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_make_boxed    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_initialize_object    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_add_relative_removable   
(/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgutil_glist2ary    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgutil_def_setters    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbg_cstr2rval    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgutil_gslist2ary    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_add_constants    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_define_class_dynamic   
(/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_ruby_object_from_instance   
(/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_boxed_get    (/usr/lib/kazehakase/ext/ruby.so)
undefined symbol: rbgobj_get_enum    (/usr/lib/kazehakase/ext/ruby.so)
$ 

The installed versions of the libraries it depends on:

apt> depends kazehakase 
kazehakase-0.5.5-alt1
  PreDepends: </bin/sh>
    sh-3.2.39-alt1
  PreDepends: </bin/sh>
    sh-3.2.39-alt1
  Depends: </lib/ld-linux.so.2>
    glibc-core-6:2.5.1-alt5
  Depends: </usr/lib/mozilla/libxpcom.so>
    seamonkey-1:1.1.11-alt1
  Depends: <libICE.so.6>
    libICE-1.0.4-alt1
  Depends: <libSM.so.6>
    libSM-1.1.0-alt1
  Depends: <libc.so.6(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.1)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.1.3)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.2)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.3)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.3.4)>
    glibc-core-6:2.5.1-alt5
  Depends: <libc.so.6(GLIBC_2.4)>
    glibc-core-6:2.5.1-alt5
  Depends: <libgcc_s.so.1(GCC_3.0)>
    libgcc4.1-4.1.2-alt3
    libgcc3.4-3.4.5-alt7
  Depends: <libgcc_s.so.1(GLIBC_2.0)>
    libgcc4.1-4.1.2-alt3
    libgcc3.4-3.4.5-alt7
  Depends: <libgcrypt.so.11(GCRYPT_1.2)>
    libgcrypt-1.4.1-alt1
  Depends: <libgdk-x11-2.0.so.0>
    libgtk+2-2.12.11-alt2
  Depends: <libgdk-x11-2.0.so.0(GDK_2.10)>
    libgtk+2-2.12.11-alt2
  Depends: <libgdk_pixbuf-2.0.so.0>
    libgtk+2-common-2.12.11-alt2
  Depends: <libglib-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.10)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.12)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.14)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.15.6)>
    glib2-2.16.5-alt1
  Depends: <libglib-2.0.so.0(GLIB_2.8)>
    glib2-2.16.5-alt1
  Depends: <libgmodule-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgnutls.so.13(GNUTLS_1_3)>
    libgnutls-2.0.4-alt2
  Depends: <libgobject-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgobject-2.0.so.0(GLIB_2.10)>
    glib2-2.16.5-alt1
  Depends: <libgobject-2.0.so.0(GLIB_2.12)>
    glib2-2.16.5-alt1
  Depends: <libgthread-2.0.so.0>
    glib2-2.16.5-alt1
  Depends: <libgtk-x11-2.0.so.0>
    libgtk+2-2.12.11-alt2
  Depends: <libgtk-x11-2.0.so.0(GTK_2.10)>
    libgtk+2-2.12.11-alt2
  Depends: <libgtk-x11-2.0.so.0(GTK_2.12)>
    libgtk+2-2.12.11-alt2
  Depends: <libm.so.6(GLIBC_2.1)>
    glibc-core-6:2.5.1-alt5
  Depends: <libnspr4.so>
    libnspr-1:4.7.2-alt1.20080628
  Depends: <libpango-1.0.so.0(PANGO_1.12)>
    libpango-1.20.5-alt1
  Depends: <libpthread.so.0(GLIBC_2.0)>
    glibc-core-6:2.5.1-alt5
  Depends: <libruby.so.1.8>
    libruby-1.8.7-alt7
  Depends: <libstdc++.so.6(CXXABI_1.3)>
    libstdc++4.1-4.1.2-alt3
    libstdc++3.4-3.4.5-alt7
  Depends: <libstdc++.so.6(GLIBCXX_3.4)>
    libstdc++4.1-4.1.2-alt3
    libstdc++3.4-3.4.5-alt7
  Depends: <libz.so.1>
    zlib-1.2.3-alt4
  Depends: <rtld(GNU_HASH)>
    glibc-core-6:2.5.1-alt5
  Depends: <ruby(erb)>
    ruby-module-erb-1.8.7-alt7
  Depends: <ruby(fileutils)>
    ruby-module-fileutils-1.8.7-alt7
  Depends: <ruby(nkf)>
    ruby-module-nkf-1.8.7-alt7
  Depends: <ruby(uri)>
    ruby-module-uri-1.8.7-alt7
apt>
------- Comment #2 From 2008-09-11 03:22:53 -------
Fixed in 0.5.5-alt2.
------- Comment #3 From 2008-09-12 14:49:14 -------
Just kazehakase-0.5.5-alt2 works fine. But I have done "apt-get install
kazehakase-ruby":

The following NEW packages will be installed:
  kazehakase-ruby ruby-atk ruby-gdkpixbuf2 ruby-glib2 ruby-gtk2 ruby-pango
0 upgraded, 6 newly installed, 0 removed and 1785 not upgraded.


and something with ruby seems to be still wrong now:

$ kazehakase 
** KzRuby WARNING **: Ruby extension disabled: failed require 'gtk2'

(kazehakase:6286): Gtk-WARNING **: RubyDialog: missing action RubyDialog

(kazehakase:6286): Gtk-WARNING **: ReloadRuby: missing action ReloadRuby

(kazehakase:6286): Gtk-WARNING **: InstallAsRubyExtension: missing action
InstallAsRubyExtension
------- Comment #4 From 2008-09-12 16:00:22 -------
У меня не воспроизвелось ни в собственной системе, ни в i586 и x86_64 хэшере.
Приведите, пожалуйста, steps to reproduce.
------- Comment #5 From 2008-09-12 16:13:44 -------
ruby-gtk2 собирается с rcairo, значит rcairo ей нужен.
------- Comment #6 From 2008-10-03 21:12:15 -------
Я научился клонировать баги, извините.  Этот баг был исправлен в пакете
kazehakase, сложные взаимоотношения ruby-gtk2 и rcairo - совсем другая история.
------- Comment #7 From 2008-10-03 21:12:56 -------
(In reply to comment #2)
> Fixed in 0.5.5-alt2.
------- Comment #8 From 2008-12-07 22:22:52 -------
(In reply to comment #4)
> У меня не воспроизвелось ни в собственной системе, ни в i586 и x86_64 хэшере.
> Приведите, пожалуйста, steps to reproduce.

steps to reproduce: ruby-gtk2-0.16.0-alt8

(In reply to comment #6)
> Я научился клонировать баги, извините.  Этот баг был исправлен в пакете
> kazehakase, сложные взаимоотношения ruby-gtk2 и rcairo - совсем другая история.
> 

apt-get-installил ruby-gtk2-0.18.0-alt1 , теперь просто падает:

$ kazehakase 
296f0748-8b91-2add-6a06d81f-1b7307d3 is dumped

kazehakase-0.5.6-alt1
kazehakase-ruby-0.5.6-alt1
------- Comment #9 From 2008-12-07 22:28:27 -------
(In reply to comment #8)

> apt-get-installил ruby-gtk2-0.18.0-alt1 , теперь просто падает:

https://bugzilla.altlinux.org/show_bug.cgi?id=18133