Bug 19168 - Missing dependencies and broken backend
: Missing dependencies and broken backend
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alterator-mkve)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-03-13 12:45 by
Modified: 2009-03-20 14:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-03-13 12:45:17
В текущей версии из git (b643125c0dc) при нажатии кнопки Configure выводится
сообщение об ошибке:
Backend: backend-communication error: ("system-error,(\"write_all\" \"~A\"
(\"Broken pipe\") (32))")

/var/log/ahttpd/access.log:
192.168.1.150   "Fri, 13 Mar 2009 09:30:19 GMT" "GET /mkve/openvz?machine=test
HTTP/1.1"        "500 - Internal server error"

/var/log/alteratord.log:
/usr/lib/alterator/backend3/mkve-openvz: line 7: alterator-net-functions: No
such file or directory

Если вручную поставить alterator-net-common, сообщение меняется на
(wrong-type-arg "string-append" "Wrong type (expecting ~A): ~S" ("string" #f)
(#f))

/var/log/alteratord.log:
/usr/lib/alterator/backend3/mkve-openvz: line 387: iptables_helper: command not
found

Ручная установка alterator-net-iptables устраняет сообщение про
iptables_helper, но не исправляет ошибку в веб-интерфейсе.
------- Comment #1 From 2009-03-13 13:05:46 -------
(В ответ на комментарий №0)
> В текущей версии из git (b643125c0dc) при нажатии кнопки Configure выводится
> сообщение об ошибке:
> Backend: backend-communication error: ("system-error,(\"write_all\" \"~A\"
> (\"Broken pipe\") (32))")
> 
> /var/log/ahttpd/access.log:
> 192.168.1.150   "Fri, 13 Mar 2009 09:30:19 GMT" "GET /mkve/openvz?machine=test
> HTTP/1.1"        "500 - Internal server error"
> 
> /var/log/alteratord.log:
> /usr/lib/alterator/backend3/mkve-openvz: line 7: alterator-net-functions: No
> such file or directory
> 
Странно.. У меня
$ apt-cache whatdepends alterator-net-common | grep mkve
  alterator-mkve-0.1-alt0.3

> Если вручную поставить alterator-net-common, сообщение меняется на
> (wrong-type-arg "string-append" "Wrong type (expecting ~A): ~S" ("string" #f)
> (#f))
У меня не воспроизводится. Обновитесь, пожалуйста, до Сизифа и попробуйте
снова.

> 
> /var/log/alteratord.log:
> /usr/lib/alterator/backend3/mkve-openvz: line 387: iptables_helper: command not
> found
> 
> Ручная установка alterator-net-iptables устраняет сообщение про
> iptables_helper, но не исправляет ошибку в веб-интерфейсе.
------- Comment #2 From 2009-03-13 13:32:18 -------
(В ответ на комментарий №1)
> Странно.. У меня
> $ apt-cache whatdepends alterator-net-common | grep mkve
>   alterator-mkve-0.1-alt0.3

Лучше сделайте
$ rpmquery --requires alterator-mkve

> > Если вручную поставить alterator-net-common, сообщение меняется на
> > (wrong-type-arg "string-append" "Wrong type (expecting ~A): ~S" ("string" #f)
> > (#f))
> У меня не воспроизводится. Обновитесь, пожалуйста, до Сизифа и попробуйте
> снова.

Обновился перед тем, как багу зафайлить.
------- Comment #3 From 2009-03-13 13:48:45 -------
(В ответ на комментарий №2)
> (В ответ на комментарий №1)
> > Странно.. У меня
> > $ apt-cache whatdepends alterator-net-common | grep mkve
> >   alterator-mkve-0.1-alt0.3
> 
> Лучше сделайте
> $ rpmquery --requires alterator-mkve
$ rpmquery --requires alterator-mkve | grep alt
alterator >= 3.3-alt8
alterator-net-common  
alterator-sh-functions 

> 
> > > Если вручную поставить alterator-net-common, сообщение меняется на
> > > (wrong-type-arg "string-append" "Wrong type (expecting ~A): ~S" ("string" #f)
> > > (#f))
> > У меня не воспроизводится. Обновитесь, пожалуйста, до Сизифа и попробуйте
> > снова.
> 
> Обновился перед тем, как багу зафайлить.
------- Comment #4 From 2009-03-13 14:31:43 -------
(В ответ на комментарий №3)

> > > Странно.. У меня
> > > $ apt-cache whatdepends alterator-net-common | grep mkve
> > >   alterator-mkve-0.1-alt0.3
> > 
> > Лучше сделайте
> > $ rpmquery --requires alterator-mkve
> $ rpmquery --requires alterator-mkve | grep alt
> alterator >= 3.3-alt8
> alterator-net-common  
> alterator-sh-functions 

Так это, небось, по contents_index вычислено. В spec-файле только

Requires: gettext
Requires: alterator >= 3.3-alt8
Requires: mkve
------- Comment #5 From 2009-03-13 14:37:33 -------
(В ответ на комментарий №4)
> (В ответ на комментарий №3)
> 
> > > > Странно.. У меня
> > > > $ apt-cache whatdepends alterator-net-common | grep mkve
> > > >   alterator-mkve-0.1-alt0.3
> > > 
> > > Лучше сделайте
> > > $ rpmquery --requires alterator-mkve
> > $ rpmquery --requires alterator-mkve | grep alt
> > alterator >= 3.3-alt8
> > alterator-net-common  
> > alterator-sh-functions 
> 
> Так это, небось, по contents_index вычислено. В spec-файле только
> 
> Requires: gettext
> Requires: alterator >= 3.3-alt8
> Requires: mkve

Добавил. См. a1003411f3a6ea8a8a8354c7828a317fdfa08972

Но странно, что у Вас все еще вылезает ошибка при нажатии "Configure". Сейчас
спрошу у advanced- альтераторщиков как это можно попробовать отладить
------- Comment #6 From 2009-03-13 14:54:12 -------
(В ответ на комментарий №5)
> > > > Лучше сделайте
> > > > $ rpmquery --requires alterator-mkve
> > > $ rpmquery --requires alterator-mkve | grep alt
> > > alterator >= 3.3-alt8
> > > alterator-net-common  
> > > alterator-sh-functions 
> > 
> > Так это, небось, по contents_index вычислено. В spec-файле только
> > 
> > Requires: gettext
> > Requires: alterator >= 3.3-alt8
> > Requires: mkve
> 
> Добавил. См. a1003411f3a6ea8a8a8354c7828a317fdfa08972

Покажите полный список $ rpmquery --requires alterator-mkve
Может, у меня ещё каких-то пакетов не хватает.
------- Comment #7 From 2009-03-13 14:58:15 -------
(В ответ на комментарий №6)
> (В ответ на комментарий №5)
> > > > > Лучше сделайте
> > > > > $ rpmquery --requires alterator-mkve
> > > > $ rpmquery --requires alterator-mkve | grep alt
> > > > alterator >= 3.3-alt8
> > > > alterator-net-common  
> > > > alterator-sh-functions 
> > > 
> > > Так это, небось, по contents_index вычислено. В spec-файле только
> > > 
> > > Requires: gettext
> > > Requires: alterator >= 3.3-alt8
> > > Requires: mkve
> > 
> > Добавил. См. a1003411f3a6ea8a8a8354c7828a317fdfa08972
> 
> Покажите полный список $ rpmquery --requires alterator-mkve
> Может, у меня ещё каких-то пакетов не хватает.
[aspsk@localhost alterator-mkve]$ rpmquery --requires alterator-mkve
gettext  
alterator >= 3.3-alt8
mkve  
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/bash  
/bin/sh  
alterator-net-common  
alterator-sh-functions  
coreutils  
findutils  
grep  
iproute2  
sed  
tar  
vzctl  
rpmlib(PayloadIsLzma) <= 4.4.2-1
------- Comment #8 From 2009-03-13 15:06:26 -------
(В ответ на комментарий №7)
> [aspsk@localhost alterator-mkve]$ rpmquery --requires alterator-mkve
Остальные пакеты все есть.
------- Comment #9 From 2009-03-13 15:45:04 -------
(В ответ на комментарий №5)
> Добавил. См. a1003411f3a6ea8a8a8354c7828a317fdfa08972

Кстати, там нет alterator-net-iptables, а ведь iptables_helper требуется. Или
это временно?
------- Comment #10 From 2009-03-13 16:47:11 -------
Исправлено в гите.
Последняя ошибка вызвана несовместимостью с alterator-fbi.