Bug 19539 - Не работает iwl3945
: Не работает iwl3945
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-def)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
: 17727
:
  Show dependency tree
 
Reported: 2009-04-08 13:56 by
Modified: 2009-04-10 13:35 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-04-08 13:56:38
При modprobe iwl3945 на kernel-image-std-def-2.6.27-alt15 выдаёт в dmesg:

Unknown parameter 'rf_kill'

Соответственно, модуль не загружается и WiFi не работает.
------- Comment #1 From 2009-04-08 14:11:14 -------
а что возвращает grep iwl3945 -r /etc/modprobe.d/ ?
------- Comment #2 From 2009-04-08 18:07:53 -------
~ $ lsmod | grep iwl
iwl3945                91764  0 
rfkill                 12824  2 iwl3945
mac80211              161308  1 iwl3945
led_class               8068  1 iwl3945
cfg80211               28040  2 iwl3945,mac80211
~ $ uname -a
Linux latitude 2.6.27-std-def-alt15 #1 SMP Tue Mar 24 15:17:22 UTC 2009 i686
GNU/Linux
~ $
------- Comment #3 From 2009-04-09 14:21:45 -------
Прекрасно (без единого неожиданного отвала) работает iwl3945 из
2.6.27-std-def-alt15, а у тебя local misconfiguration.  См. комментарий Миши.
------- Comment #4 From 2009-04-09 15:31:11 -------
(В ответ на комментарий №3)
> Прекрасно (без единого неожиданного отвала) работает iwl3945 из
> 2.6.27-std-def-alt15, а у тебя local misconfiguration.  См. комментарий Миши.
Я согласен, что это локальная конфигурация. Обновлялись из 4.0.
------- Comment #5 From 2009-04-10 13:35:41 -------
(В ответ на комментарий №4)
> > Прекрасно (без единого неожиданного отвала) работает iwl3945 из
> > 2.6.27-std-def-alt15, а у тебя local misconfiguration.  См. комментарий Миши.
> Я согласен, что это локальная конфигурация. Обновлялись из 4.0.
А.  Так такое стоит указывать обязательно, ну и бага не на ядро, а на
отсутствующий у нас пакет, в котором можно было бы фиксировать костыли для
подобных известных изменений при переездах.  Кажется, в убунте update manager
некий есть на эту тему.

Этим давно стоило заняться, но у меня руки не доходили, а кому-то предлагать --
смыслу нет.  Но раз уж зашла речь...