Bug 20330 - -LNONE в выводе imlib2-config
: -LNONE в выводе imlib2-config
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/imlib2-devel)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-05 09:19 by
Modified: 2011-07-07 13:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-05 09:19:31
$ /usr/bin/imlib2-config --libs
-lImlib2 -lfreetype -lz -LNONE -lX11 -lXext -ldl -lm
$ rpm -q imlib2-devel
imlib2-devel-1.4.0-alt3

Это сильно мешает libtool работать. С вот такой диагностикой:
./libtool: line 4973: cd: NONE: No such file or directory
libtool: link: cannot determine absolute directory name of `NONE'

Либо починить скрипт, либо выкинуть нафиг. Скорее второе, потому что pkg-config
выдаёт вполне правильные параметры.
------- Comment #1 From 2009-06-06 13:37:42 -------
(В ответ на комментарий №0)
> Либо починить скрипт, либо выкинуть нафиг. Скорее второе, потому что pkg-config
> выдаёт вполне правильные параметры.

"Вернее, следует превратить imlib2-config в обёртку вокруг imlib2.pc." (с) ldv@

См.: http://lists.altlinux.org/pipermail/devel/2009-March/167885.html
------- Comment #2 From 2009-08-21 07:47:35 -------
*** Bug 21161 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2011-07-07 13:47:29 -------
pad:~> imlib2-config --libs
-lImlib2 -lfreetype -L/usr/X11R6/lib -lX11 -lXext -ldl -lm
pad:~> rpm -qf =imlib2-config
imlib2-devel-1.4.4-alt2.qa2