Bug 20525 - Не удайтся добавить в исключения Firefox сертификат сервера
: Не удайтся добавить в исключения Firefox сертификат сервера
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firefox-settings-simple)
: unstable
: x86_64 Linux
: P3 blocker
Assigned To:
:
:
:
:
: 23155
  Show dependency tree
 
Reported: 2009-06-21 20:33 by
Modified: 2010-11-15 08:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-21 20:33:32
Technology Preview 5.0.

Равзвернул сервер по-умолчанию с двумя интерфейсами и клиент (KDE4). На клиенте
ещё нет доступа в Интернет, таким образом.

При первом же запуске климента и заходе на https://192.168.0.1:8080 (адрес
сервера) Firefox ругается на сертификат, и при нажатии на "Добавить исключение"
ничего не происходит, стандартного диалога не появляется.
------- Comment #1 From 2010-11-01 17:29:29 -------
Обновился недавно до сизифа, и тоже словил эту ошибку.

При нажатии "Добавить исключение" действительно ничего не происходит.

Притом ошибка более глобальная, ибо у меня криво работает TabMixPlus и менеджер
паролей.
------- Comment #2 From 2010-11-01 17:31:07 -------
С чистым профилем проверял - воспроизводится стабильно!
------- Comment #3 From 2010-11-01 17:35:42 -------
Нужно больше информации. Какой там сертификат?
------- Comment #4 From 2010-11-02 13:16:43 -------
ну например тут можно глянуть:
https://spdesign.ru.mail.masterhost.ru/cgi-bin/qmailadmin
------- Comment #5 From 2010-11-02 13:55:39 -------
(В ответ на комментарий №4)
> ну например тут можно глянуть:
> https://spdesign.ru.mail.masterhost.ru/cgi-bin/qmailadmin

firefox-3.6-3.6.12-alt1.20101025 - исключение добавилось.
firefox-minefield-4.0b6pre-alt1  - исключение добавилось.
------- Comment #6 From 2010-11-02 14:38:16 -------
[oxyum@t510 ~]$ mv .mozilla/ .mozilla.bak
[oxyum@t510 ~]$ rpm -qa "firefox*" | sort
firefox-3.6-3.6.12-alt1.20101025
firefox-adblock_plus-1.2.2-alt1
firefox-ru-3.6.0-alt1
firefox-settings-simple-0.1-alt2
firefox-webdeveloper-1.1.8-alt2
[oxyum@t510 ~]$ firefox 
Mozilla XULRunner 1.9.2.12pre - 20101026061017

(xulrunner:24740): Gtk-WARNING **: Error loading theme icon 'gtk-go-back-ltr'
for stock: Значок «gtk-go-back-ltr» не присутствует в теме

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

** (xulrunner:24740): CRITICAL **: gtkRenderIcon: assertion `base_pixbuf !=
NULL' failed

(xulrunner:24740): Gtk-CRITICAL **: IA__gtk_style_render_icon: assertion
`pixbuf != NULL' failed

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

(xulrunner:24740): Gtk-WARNING **: Error loading theme icon
'gtk-go-forward-ltr' for stock: Значок «gtk-go-forward-ltr» не присутствует в
теме

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

** (xulrunner:24740): CRITICAL **: gtkRenderIcon: assertion `base_pixbuf !=
NULL' failed

(xulrunner:24740): Gtk-CRITICAL **: IA__gtk_style_render_icon: assertion
`pixbuf != NULL' failed

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed

(xulrunner:24740): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed
[oxyum@t510 ~]$
------- Comment #7 From 2010-11-02 14:45:03 -------
Грохнул firefox-settings-simple-0.1-alt2 и менеджер паролей и сертификатов
начали нормально работать!

Похоже надо выкинуть этот пакет из репозитория нафик и закрыть баг!

PS: Ставил его из-за того, что после обновления до этой версии FF у меня криво
работал TabMixPlus и я искал способы починки.
------- Comment #8 From 2010-11-02 14:48:16 -------
(In reply to comment #6)
> firefox-settings-simple-0.1-alt2

Ну это кагбе младший брат bug 19252.
------- Comment #9 From 2010-11-02 22:36:02 -------
> Похоже надо выкинуть этот пакет из репозитория нафик и закрыть баг!

я не могу обещать, что быстро его вылечу а потому да, выкидываю до лучших
времен
------- Comment #10 From 2010-11-02 22:37:43 -------
task #31881 и task #31882
------- Comment #11 From 2010-11-02 22:42:58 -------
(In reply to comment #7)
> PS: Ставил его из-за того, что после обновления до этой версии FF у меня криво
> работал TabMixPlus и я искал способы починки.
apt-get install firefox-tab_kit ;-)