Bug 20833 - sip: /usr/share/sip/PyQt4/QtCore/QtCoremod.sip:115: syntax error
: sip: /usr/share/sip/PyQt4/QtCore/QtCoremod.sip:115: syntax error
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-PyQt4-devel)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://bugs.gentoo.org/show_bug.cgi?i...
:
:
:
  Show dependency tree
 
Reported: 2009-07-20 15:14 by
Modified: 2009-07-21 16:51 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-07-20 15:14:13
rpm -qa | grep sip
python-module-sip-devel-4.8.1-alt1
python-module-sip-4.8.1-alt1

pm -qa | grep PyQt
python-module-PyQt4-devel-4.4.4-alt1
python-module-PyQt4-examples-4.4.4-alt1
python-module-PyQt4-doc-4.4.4-alt1
python-module-PyQt4-4.4.4-alt1

PyQt-4.4.4.4 packages should be build with sip-4.7.9. If you use sip-4.8
you need to upgrade your PyQt to PyQt4-4.5 as well
------- Comment #1 From 2009-07-20 15:17:23 -------
already done:
#9586 AWAITING sisyphus python-module-PyQt4.git=4.5.2-alt1
------- Comment #2 From 2009-07-20 15:45:16 -------
надо как-то все продукты от riverbankcomputing.co.uk обновлять скопом, чтоб
несобираемость части из них не была сюрпризом-)
------- Comment #3 From 2009-07-20 15:47:57 -------
Там совместимость поправили, предыдущий релиз (4.5.1) вываливался на проверке
питона после сборки
------- Comment #4 From 2009-07-20 15:50:19 -------
это прекрасно-)
собственно я к тому, что можно так же и qscintilla обновлять одним таском ;-)
------- Comment #5 From 2009-07-20 15:55:23 -------
я понял... Видимо, да... так и стоит...
------- Comment #6 From 2009-07-20 17:40:23 -------
(В ответ на комментарий №2)
> надо как-то все продукты от riverbankcomputing.co.uk обновлять скопом, чтоб
> несобираемость части из них не была сюрпризом-)

Еще в старые добрые времена incoming и srpms я так и делал, а потом sin@
сказал, что он готов их поддерживать и я был счастлив спихнуть этот набор ему!
:)
------- Comment #7 From 2009-07-21 16:51:41 -------
fixed