Bug 21480 - [GNOME Desktop] нет пакетов hplip и hplip-PPDs
: [GNOME Desktop] нет пакетов hplip и hplip-PPDs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mkimage-profiles-desktop)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 19564
  Show dependency tree
 
Reported: 2009-09-08 15:51 by
Modified: 2009-10-20 11:26 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-09-08 15:51:54
В Desktop (с KDE) такие пакеты есть. Может, добавить?
------- Comment #1 From 2009-09-29 11:49:14 -------
hplip-hpijs и hplip-sane есть, а остальные, насколько я понимаю не нужны
------- Comment #2 From 2009-09-29 14:24:59 -------
А как же ppd для HPшных принтеров (hplip-PPDs)? Появятся ли в списках принтеров
модели HP?

Игорь, нужно ли ставить hplip-PPDs?
------- Comment #3 From 2009-09-29 23:42:26 -------
(В ответ на комментарий №2)
> А как же ppd для HPшных принтеров (hplip-PPDs)? Появятся ли в списках принтеров
> модели HP?
> 
> Игорь, нужно ли ставить hplip-PPDs?

Хорошие вопросы.
Встречный вопрос - в каких списках? alterator-printers выроде бы давно сломан.
Имеется в виду веб-интерфейс к cups?
Или как принтеры штатно должны настраиваться?
Я к сож. не в курсе как с этим дела в Сизифе.

И есть тонкости.
hpijs не дает всех возможностей hplip.

Хотелось бы узнать, будет ли тянуться hplip или только hpijs.
если только hpijs, то там еще кусок работы по ветке 3.x :(
------- Comment #4 From 2009-09-30 13:02:05 -------
(В ответ на комментарий №3)
> Имеется в виду веб-интерфейс к cups?
Да. Там же читаются все доступные .ppd

> Или как принтеры штатно должны настраиваться?
Именно через веб-интерфейс. KDEшнвя настраивалка использует тот же механизм,
что и веб-интерфейс.

> Хотелось бы узнать, будет ли тянуться hplip или только hpijs.
Тянутся оба пакета. Вопрос был в том, нужен ли ещё и hplip-PPDs?
------- Comment #5 From 2009-09-30 13:35:42 -------
Вопрос не такой простой, как кажется.
для настройки принтера нужен ppd, но он может
1) явно находиться в системе как ppd или ppd.gz файл.
2) генерироваться из foomatic-db
3) генерироваться из cups DRV (cups >= 1.3.0)
hplip 3.x начал поддерживать cups DRV.

пакет hplip тащит с собой 
/usr/share/cups/drv/hp/hpcups.drv
/usr/share/cups/drv/hp/hpijs.drv
т.е. при настройке через чистый cups web interface hplip-PPD не нужен,
cups должен видеть cups DRV.
но - KDEшнвя настраивалка мне не знакома.
не могли бы вы проверить? я на 41 сижу сейчас.
------- Comment #6 From 2009-09-30 16:28:46 -------
(В ответ на комментарий №5)
> не могли бы вы проверить? я на 41 сижу сейчас.
Могу. Пример модели принтера можешь привести?
------- Comment #7 From 2009-09-30 16:33:57 -------
(В ответ на комментарий №6)
> (В ответ на комментарий №5)
> > не могли бы вы проверить? я на 41 сижу сейчас.
> Могу. Пример модели принтера можешь привести?

думаю, в силу своей экзотичности пойдет
HP Deskjet 1280
------- Comment #8 From 2009-09-30 17:27:33 -------
(В ответ на комментарий №7)
> (В ответ на комментарий №6)
> > (В ответ на комментарий №5)
> > > не могли бы вы проверить? я на 41 сижу сейчас.
> > Могу. Пример модели принтера можешь привести?
> 
> думаю, в силу своей экзотичности пойдет
> HP Deskjet 1280
_Без_ hplip-PPDs все три средства настройки: CUPS, KDE3, KDE4 показывают 
HP DeskJet 1280 Foomatic/hpijs (en)

При установке hplip-PPDs добавляется ещё две разновидности модели:
HP DeskJet 1280 hpijs
HP DeskJet 1280 hpcups

А вот нужно ли это — не знаю.
------- Comment #9 From 2009-09-30 17:52:21 -------
(В ответ на комментарий №8)
> > HP Deskjet 1280
> _Без_ hplip-PPDs все три средства настройки: CUPS, KDE3, KDE4 показывают 
> HP DeskJet 1280 Foomatic/hpijs (en)
> 
> При установке hplip-PPDs добавляется ещё две разновидности модели:
> HP DeskJet 1280 hpijs
> HP DeskJet 1280 hpcups
> 
> А вот нужно ли это — не знаю.

плохо дело. похоже, cups DRV не видны cups.
а HP DeskJet 1280 Foomatic/hpijs (en) --- это как раз не слишком good.
это записи из foomatic-db, но апстрим недавно объявил их устаревшими:
<quote>
Announcement: Foomatic 4.0.3 released!

This release fixes several bugs and drops the foomatic-db-hpijs package.

As HPLIP ships CUPS-DDK-generated PPD files for some time and also added a CUPS
Raster driver, we have decided to drop the foomatic-db-hpijs package as it is
not maintained any more by HP and so the PPDs generated by it got out-of-date.
PPDs for non-HP printers used with HPIJS are now generated by foomatic-db, via
the driver entries "hpijs-pcl3", "hpijs-pcl5e", and "hpijs-pcl5c". For HP
printers the new driver entry "hplip" was introduced to reference to the full
HPLIP driver suite. The "hpijs" driver entry got dropped.
</quote>

В общем, это мне пища для ума. перед тем как обновлять foomatic-db,
надо допилить hplip.

одним словом, hplip-PPD ложить не нужно,
но похоже найден баг в связке hplip+cups.
------- Comment #10 From 2009-10-01 13:58:28 -------
Раз не нужно - закрываю.
------- Comment #11 From 2009-10-20 11:26:35 -------
Попробуйте с cups-1.4.1-alt4 (отправлен на сборку только что).
Я там исправил упаковку пакета и перенёс некоторые каталоги из devel части в
основную. У меня без установленного foomatic-db успешно добавился принтер из
hplip.

(В ответ на комментарий №8)
> (В ответ на комментарий №7)
> > (В ответ на комментарий №6)
> > > (В ответ на комментарий №5)
> > > > не могли бы вы проверить? я на 41 сижу сейчас.
> > > Могу. Пример модели принтера можешь привести?
> > 
> > думаю, в силу своей экзотичности пойдет
> > HP Deskjet 1280
> _Без_ hplip-PPDs все три средства настройки: CUPS, KDE3, KDE4 показывают 
> HP DeskJet 1280 Foomatic/hpijs (en)
> 
> При установке hplip-PPDs добавляется ещё две разновидности модели:
> HP DeskJet 1280 hpijs
> HP DeskJet 1280 hpcups
> 
> А вот нужно ли это — не знаю.

(В ответ на комментарий №10)
> Раз не нужно - закрываю.