Bug 22319 - advertising itself for zeroconf (dnssd) and using other dnssd published printers
: advertising itself for zeroconf (dnssd) and using other dnssd published printers
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/cups)
: unstable
: all Linux
: P3 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-17 15:32 by
Modified: 2013-10-21 15:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-17 15:32:28
cups-1.4.2-alt0.M51.1

It'd be nice if cups advertised itself for zeroconf (a use case:
http://blog.venthur.de/2007/08/17/howto-setup-a-print-server-for-windows-and-others-using-cups-and-zeroconf/
).

But, as it can be seen in the "Advanced" view of https://localhost:631/admin in
cups-1.4.2-alt0.M51.1, "dnssd" protocol is not available as a "Browse*Protocol"
option.

Perhaps, that's because CUPS hasn't been compiled with avahi --
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/465916/comments/1 .

dnssd advertising didn't work either in cups-1.3.9-alt2.
------- Comment #1 From 2009-11-17 15:37:20 -------
(In reply to comment #0)

> dnssd advertising didn't work either in cups-1.3.9-alt2.

I tested it by switching it on in the web interface or in /etc/cups/cupsd.conf,
and then looking through " avahi-browse -a" or "avahi-discover".
------- Comment #2 From 2010-04-20 11:26:37 -------
Собранный в АльтЛинукс cups не поддерживает Avahi, ведущую реализацию протокола
dnssd под Linux

В
http://git.altlinux.org/people/morozov/packages/cups.git?p=cups.git;a=shortlog;h=refs/heads/alm
есть подготовленный пакет с патчем имени RH/Fedora, который решает эту
проблему. Пакет выглядит работающим (с моей точки зрения)

Кроме того, следует подумать об инкорпорировании других патчей из Fedora,
некоторые из них выглядят небесполезными.

The cups package in ALTLinux doesn't support Avahi, the leading DNSSD protocol
implementation under Linux.

There's a prepared package in
http://git.altlinux.org/people/morozov/packages/cups.git?p=cups.git;a=shortlog;h=refs/heads/alm
with RH/Fedora-originated patch to solve this problem. The package looks
working, at least for me.

BTW one should consider other patches from RH/Fedora as well, at least some of
them worth attention.
------- Comment #3 From 2010-04-25 00:14:11 -------
Давайте-ка с этим на сизифный пакет, чтоб не потерялось.
------- Comment #4 From 2013-07-12 04:08:42 -------
*** Bug 29118 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2013-10-21 15:25:03 -------
It seems like current CUPS 1.6.2 does this already