Bug 29118 - Не работает сетевой принтер из-за интерфейса org.freedesktop.ColorManager
: Не работает сетевой принтер из-за интерфейса org.freedesktop.ColorManager
Status: CLOSED DUPLICATE of bug 22319
: Sisyphus
(All bugs in Sisyphus/cups)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: https://bbs.archlinux.org/viewtopic.p...
:
:
:
  Show dependency tree
 
Reported: 2013-06-28 14:03 by
Modified: 2013-08-28 19:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-06-28 14:03:25
После обновления до версии cups-1.6.2-alt3 перестал работать удалённый принтер,
подключенный через через BrowseAddress 192.168.3.255 (ручное подключение также
не помогло). С других компьютеров на p6 принтер работает.

Ошибка в /var/log/cups/error_log выглядит следующим образом:

W [25/Jun/2013:22:11:33 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Cups_PDF
W [25/Jun/2013:22:11:33 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Cups_PDF
W [25/Jun/2013:22:11:33 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Virtual_PDF_Printer
W [25/Jun/2013:22:11:33 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Virtual_PDF_Printer

Подобная проблема проявлялась в разных сборка, в последнее время:
https://bugzilla.redhat.com/show_bug.cgi?id=701296
https://bbs.archlinux.org/viewtopic.php?pid=1255639
https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/1053443
http://forums.scotsnewsletter.com/index.php?showtopic=60702


Есть подозрение, что проблема может быть в одном из оторванных патчей:
$ rpm -q --lastchange cups
* Ср май 29 2013 Alexander Plehanov <tonik@altlinux.org> 1.6.2-alt3
- Remove patches,which were applied in upstream version:
    cups-1.6.1-defconf.patch
    cups-1.5.4-rh-usblp-quirks.patch
   
cups-1.6.1-ubuntu-prevent-crash-due-to-null-host-name-or-fqdn-from-avahi.patch
    cups-1.6.1-ubuntu-fix-crash-on-shutdown-caused-by-broken-avahi-config.patch
   
cups-1.6.1-ubuntu-ipp-backend-abort-the-outer-loop-if-we-get-a-failure-from-send-document.patch
   
cups-1.6.1-ubuntu-ipp-backend-could-get-stuck-in-an-endless-loop-on-certain-network-errors.patch
   
cups-1.6.1-ubuntu-fix-another-spot-where-avahi-crashes-cupsd-because-it-does-not-handle-null-values-from-its-own-apis.patch
   
cups-1.6.1-ubuntu-ipp-backend-did-not-send-cancel-request-to-printers-when-a-job-was-canceled-and-printer-did-not-support-create-job.patch
   
cups-1.6.1-ubuntu-get-ppd-file-for-statically-configured-bonjour-shared-queues.patch
   
cups-1.6.1-ubuntu-printers-c-recognize-remote-cups-queue-via-dnssd-uri.patch

- Remove unneeded patches:
    cups-1.6.1-ubuntu-forward-port-cups-1-5-x-cups-browsing.patch
    cups-1.6.1-alt-makefile.patch -> updated in cups-1.6.2-alt-makefile.patch

- Updated patches:
    cups-1.6.0-debian-pidfile.patch
    cups-1.6.1-rh-lspp.patch
    cups-1.6.1-ubuntu-airprint-support.patch
    cups-1.6.1-ubuntu-cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
------- Comment #1 From 2013-07-12 04:08:41 -------
Обнаружил, что проблема поиска сетевых принтеров рассматривалась в задаче:
https://bugzilla.altlinux.org/show_bug.cgi?id=22319

Смог сделать обходной вариант решения - прописать ServerName <ИмяСервера>
вручную на клиенте в файле /etc/cups/client.conf.

Более подробно описание опций сервера есть в документации:
http://www.cups.org/documentation.php/ref-cupsd-conf.html

Заметил также, что в новой версии cups-1.6.1-alt3 ряд опций и протоколов
устарел, в частности, BrowseRemoteProtocols CUPS - не поддерживаются:
E [12/Jul/2013:04:01:03 +0400] Unknown browse protocol "cups" ignored.

Насколько я понял, текущий вариант cups-1.6.1 предполагает поиск через
ZeroConf. Тут тоже проблема - avahi-discover ничего не показывает для принтера
http://atxconsulting.com/posts/Automatically_generate_AirPrint_Avahi_service_files_for_CUPS_printers/


Для исправления проблемы в colord установил пакет libcolord-gir - не помогло:
W [12/Jul/2013:04:01:03 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Cups_PDF
W [12/Jul/2013:04:01:03 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Cups_PDF
W [12/Jul/2013:04:01:03 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Virtual_PDF_Printer
W [12/Jul/2013:04:01:03 +0400] AddProfile failed:
org.freedesktop.DBus.Error.UnknownMethod:No such interface
`org.freedesktop.ColorManager' on object at path
/org/freedesktop/ColorManager/devices/cups_Virtual_PDF_Printer

*** This bug has been marked as a duplicate of bug 22319 ***