Bug 22353 - Наверное уже стоит собрать новую версию?
: Наверное уже стоит собрать новую версию?
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/seamonkey)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-21 14:18 by
Modified: 2011-06-03 11:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-21 14:18:18
Уже давно вышла, а у нас её всё нет.
------- Comment #1 From 2010-02-10 17:50:29 -------
Seamonkey 2.0.2 так и не собирается?
------- Comment #2 From 2010-10-09 16:03:32 -------
Очевидно, пакет ищет майнтейнера.
------- Comment #3 From 2011-01-14 11:55:27 -------
Если Дамир не хочет его больше, я готов принять его.
Используйте% Subj много.
------- Comment #4 From 2011-01-14 12:05:05 -------
(В ответ на комментарий №3)
> Если Дамир не хочет его больше, я готов принять его.
> Используйте% Subj много.

Alex, это было бы замечательно!
------- Comment #5 From 2011-01-14 12:18:53 -------
Ну, в эти дни новая версия (2.0.11) появится в гите.
------- Comment #6 From 2011-03-02 00:05:44 -------
Alex, удалось ли собрать новую версию? Морально поддерживаю вас :)
------- Comment #7 From 2011-04-02 20:41:40 -------
still trying :( for the moment am solving #25331
------- Comment #8 From 2011-04-03 12:29:05 -------
I managed to build new version (2.0.13), but it crashes during spell checking,
now trying to build it with system hunspell.
------- Comment #9 From 2011-04-03 16:32:07 -------
same here:
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail+0x37)[0x7f1f91076727]
/lib64/libc.so.6(+0xe4650)[0x7f1f91074650]
/home/alecs/RPM/tmp/sm/usr/lib/seamonkey-2.0.11/components/libspellchecker.so(+0x1ec9f)[0x7f1f7c12ec9f]
/home/alecs/RPM/tmp/sm/usr/lib/seamonkey-2.0.11/components/libspellchecker.so(+0x1f389)[0x7f1f7c12f389]
/home/alecs/RPM/tmp/sm/usr/lib/seamonkey-2.0.11/components/libspellchecker.so(+0x1f4e7)[0x7f1f7c12f4e7]
------- Comment #10 From 2011-04-03 17:04:38 -------
Look at my git, I built it with system hunspell using --enable-system-hunspell,
and adding libhunspell-devel to BuildRequires.
------- Comment #11 From 2011-04-03 17:11:49 -------
I did it too. Configure was:
./configure --prefix=%_prefix --enable-application=suite --with-pthreads
--with-user-appdir=.seamonkey --enable-application=suite
--disable-official-branding --disable-debug --enable-optimize --enable-64bit
--cache-file=.././config.cache --srcdir=. --enable-system-hunspell
--with-system-zlib --without-system-png --with-system-jpeg
--with-default-mozilla-five-home=%seamonkey_home --with-user-appdir=.seamonkey
--disable-crashreporter --disable-updater --disable-installer
------- Comment #12 From 2011-04-03 17:26:24 -------
Are you running the build too ? or we test some more :)
------- Comment #13 From 2011-04-03 17:28:15 -------
I put a tag into my git, which can be built on modern sisyphus and that works
correctly with spell checking. For some reason, I can't create a mail account
(using seamonkey-mail package), so mail is not working there, but browser works
fine.
------- Comment #14 From 2011-04-03 17:36:20 -------
I'm now cloning your git and building yours to see what's happend.
Earlier all worked, but I had another config as you have seen.
------- Comment #15 From 2011-05-10 21:31:32 -------
http://git.altlinux.org/tasks/44287

Прошу тестировать.
Пока есть проблемы с debuginfo, но сама симанка работает.
Так как Seamonkey - это все-таки больше комбайн, я счел нецелесообразным
распиливание его на несколько подпакетов. Все одним пакетом.
Для тех, кто хочет нарезку, прошу использовать FF и TB. 

P.S. В сизиф не проходит из-за этого:
http://git.altlinux.org/tasks/44287/task/log.2.1
------- Comment #16 From 2011-05-10 21:36:18 -------
Самое главное - проверить, работает ли почтовый клиент. Потому что в моих
сборках он не работал вообще.
------- Comment #17 From 2011-06-02 00:43:07 -------
(В ответ на комментарий №16)
> Самое главное - проверить, работает ли почтовый клиент. Потому что в моих
> сборках он не работал вообще.

Проверил, работает.
Нужно дождаться пока он таки пролезет в сизиф.
Кстати, я добавил зависимость на libsqlite3, поэтому использование почтового
клиента не должно вызвать проблем.
------- Comment #18 From 2011-06-03 07:37:07 -------
Новая версия в сизифе.
После тестирования её можно будет переносить в остальные репо.
------- Comment #19 From 2011-06-03 11:29:01 -------
(В ответ на комментарий №18)
> Новая версия в сизифе.
> После тестирования её можно будет переносить в остальные репо.

Спасибо!!