Bug 23494 - devanagari rendering messed up (with diacritics)
: devanagari rendering messed up (with diacritics)
Status: ASSIGNED
: Sisyphus
(All bugs in Sisyphus/chromium)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://code.google.com/p/chromium/iss...
:
:
:
  Show dependency tree
 
Reported: 2010-05-18 07:51 by
Modified: 2012-08-15 12:09 (History)


Attachments
chromium-devanagari-bad.png (9.15 KB, image/png)
2010-05-18 07:51, Ivan Zakharyaschev
no flags Details
konqueror-devanagari-good.png (7.22 KB, image/png)
2010-05-18 07:52, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-05-18 07:51:38
Created an attachment (id=4389) [details]
chromium-devanagari-bad.png

chromium-browser-6.0.401.0-alt1.r47010
libgtk+2-2.20.1-alt1
libpango-1.28.0-alt1
libcairo-1.8.10-alt1

The rendering of Devanagari is messed up, especially in case of some
diacritics, such as vowel "u" or vowel "e" sign. As an example, I attach the
screenshot of a part (a title of a section) of http://hi.wikipedia.org , as
displayed in Chromium, and as displayed in kdebase-konqueror-3.5.10-alt4.M41.1
(konqueror renders it correctly).

Also, gedit renders these words correctly.
------- Comment #1 From 2010-05-18 07:52:58 -------
Created an attachment (id=4390) [details]
konqueror-devanagari-good.png
------- Comment #2 From 2010-05-18 10:12:06 -------
Не вижу разницы. Пишите в апстрим.
------- Comment #3 From 2010-05-20 05:39:42 -------
A similar problem: https://bugzilla.altlinux.org/show_bug.cgi?id=23513 .
------- Comment #4 From 2010-05-20 10:12:57 -------
*** Bug 23513 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2012-08-15 12:09:03 -------
Please, check chromium-21.0.1158.0 for this problem. It seems it is fixed in
new version of Chromium.