Bug 2368 - apt 0.5.5cnc4.1-alt1 много неудовлетворительных зависимостей
: apt 0.5.5cnc4.1-alt1 много неудовлетворительных зависимостей
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-03-12 19:52 by
Modified: 2008-03-01 15:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-03-12 19:52:55
С apt 0.5.5cnc3-alt1 все нормально. после обновления на apt 0.5.5cnc4.1-alt1 -
при apt-get check - много depends (на bzlib, gdm, drackfloppy, drakxtools,
glibc-core, kernel24-up). на один раз спасает удаление /var/cache/apt/*.bin.
потом снова тоже самое. 
---

---
------- Comment #1 From 2003-03-12 20:34:31 -------
У меня не воспроизводится.
------- Comment #2 From 2003-03-12 20:34:31 -------
У меня не воспроизводится.
------- Comment #3 From 2003-03-14 09:58:50 -------
Специально проделал все второй раз.
1) устанавливаем Master 2.2 по сети через ftp (ftp.altlinux.ru) в минимальной конфигурации.
2) apt настраиваем на сизиф.
3) apt-get update/apt-get dist-upgrade  в числе обновлений и apt b др.пакеты.
4) после этого(или установив еще какой-либо пакет) еще что-то устанвить через apt не возможно, так как например bzlib требует /etc/security/console.apps (хотя это есть в системе)
5) удаляем /var/cache/apt/*.bin, устанавливаем еще что-нибудь - ок. потом опять ругань на зависимости. Впечатления что /var/cache/apt/*.bin - не обновляется.  Сама база RPM вроде нормально обновляется и работает коректно.
6) откатываемя на предыдущий apt - работает все нормально.
------- Comment #4 From 2003-03-14 09:58:50 -------
Специально проделал все второй раз.
1) устанавливаем Master 2.2 по сети через ftp (ftp.altlinux.ru) в минимальной конфигурации.
2) apt настраиваем на сизиф.
3) apt-get update/apt-get dist-upgrade  в числе обновлений и apt b др.пакеты.
4) после этого(или установив еще какой-либо пакет) еще что-то устанвить через apt не возможно, так как например bzlib требует /etc/security/console.apps (хотя это есть в системе)
5) удаляем /var/cache/apt/*.bin, устанавливаем еще что-нибудь - ок. потом опять ругань на зависимости. Впечатления что /var/cache/apt/*.bin - не обновляется.  Сама база RPM вроде нормально обновляется и работает коректно.
6) откатываемя на предыдущий apt - работает все нормально.
------- Comment #5 From 2003-04-22 22:18:34 -------
После обновления apt до версии 0.5.5cnc4.1-alt1 имел теже проблемы ругань была
на следующие пакеты: 
  bzlib: требует: /sbin/bzlib_triggerpostun
  drakconf: требует: /etc/security/console.apps
  drakfloppy: требует: /etc/security/console.apps
  drakxtools: требует: /usr/X11R6/bin/xtest
              требует: /etc/security/console.apps
  glibc-core: требует: /sbin/glibc_post_upgrade
              требует: /sbin/glibc_fix_nsswitch
  glibc-core-i686: требует: /sbin/glibc_post_upgrade
  kbdrate-usermode: требует: /etc/security/console.apps
  kernel24-up#2.4.20-alt7: требует: /usr/sbin/rdev
  kwintv: требует: /usr/sbin/chkfontpath
          требует: /etc/security/console.apps
  latex2html: требует: /usr/bin/mktexlsr
  synaptic-usermode: требует: /etc/security/console.apps
  userdrake: требует: /etc/security/console.apps
При возврате к предыдущей версии apt-get check выдает что все нормально
------- Comment #6 From 2003-04-22 22:18:34 -------
После обновления apt до версии 0.5.5cnc4.1-alt1 имел теже проблемы ругань была
на следующие пакеты: 
  bzlib: требует: /sbin/bzlib_triggerpostun
  drakconf: требует: /etc/security/console.apps
  drakfloppy: требует: /etc/security/console.apps
  drakxtools: требует: /usr/X11R6/bin/xtest
              требует: /etc/security/console.apps
  glibc-core: требует: /sbin/glibc_post_upgrade
              требует: /sbin/glibc_fix_nsswitch
  glibc-core-i686: требует: /sbin/glibc_post_upgrade
  kbdrate-usermode: требует: /etc/security/console.apps
  kernel24-up#2.4.20-alt7: требует: /usr/sbin/rdev
  kwintv: требует: /usr/sbin/chkfontpath
          требует: /etc/security/console.apps
  latex2html: требует: /usr/bin/mktexlsr
  synaptic-usermode: требует: /etc/security/console.apps
  userdrake: требует: /etc/security/console.apps
При возврате к предыдущей версии apt-get check выдает что все нормально
------- Comment #7 From 2003-08-18 15:25:34 -------
Поскольку мы решили, что эта проблема пакетов, а не apt\'а, то исправлены были
сами пакеты.
------- Comment #8 From 2003-08-18 15:25:34 -------
Поскольку мы решили, что эта проблема пакетов, а не apt\'а, то исправлены были
сами пакеты.