Bug 24578 - x86_32 часто разломан
: x86_32 часто разломан
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/arepo)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
: 23878
: 23155
  Show dependency tree
 
Reported: 2010-11-16 16:58 by
Modified: 2012-04-02 19:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-11-16 16:58:43
x86_32 разломан с 13-го числа
------- Comment #1 From 2010-11-16 17:48:42 -------
Не, это, похоже локально. Сначала окончательно выясню.
------- Comment #2 From 2010-11-17 17:26:52 -------
Да, сегодня уже другие разломы
------- Comment #3 From 2010-11-18 11:32:52 -------
Сама модель "раз в сутки всё централизованно пересоберём", которая сейчас
реализована в arepo, работает только при выпуске дистрибутива. На постоянно
меняющемся репозитории она, разумеется, всегда отстаёт. Если есть желание это
исправить, надо встраиваться в сборочницу.
------- Comment #4 From 2010-11-25 16:00:26 -------
(В ответ на комментарий №3)
> надо встраиваться в сборочницу.
Все толко за ;-)
------- Comment #5 From 2010-11-25 17:15:05 -------
Ну так видимо нужно указать другого исполнителя данной задачи?
------- Comment #6 From 2010-11-25 17:27:24 -------
В зависимостях стоит #23878
------- Comment #7 From 2010-12-23 11:26:37 -------
Попробовал:
ftp://updates.etersoft.ru/pub/ALTLinux/Sisyphus/x86_32/
и
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/x86_32/
Все на сизифе.
Пытался ставить скайп как сказано тут: http://www.altlinux.org/Skype на 64х
битную машину. Не удалось. Все еще все сломано?
------- Comment #8 From 2010-12-23 14:35:32 -------
(В ответ на комментарий №7)
> Все еще все сломано?
См. #3
Как только обновляется любой из пакетов, присутствующих в x86_32, он переходит
в состояние "сломан". Как только ничего там не обновляется с сизифом,
"чиниться"
------- Comment #9 From 2010-12-23 15:15:27 -------
(В ответ на комментарий №8)
> (В ответ на комментарий №7)
> > Все еще все сломано?
> См. #3
> Как только обновляется любой из пакетов, присутствующих в x86_32, он переходит
> в состояние "сломан". Как только ничего там не обновляется с сизифом,
> "чиниться"

Ух... 
Можно ли что-то сделать, чтобы оно _внезапно_ заработало?
------- Comment #10 From 2010-12-23 15:45:36 -------
(В ответ на комментарий №9)
> Можно ли что-то сделать, чтобы оно _внезапно_ заработало?
4 варианта, как-минимум:
- реализовать синхронное обновление x86_32 и сизифа
- сделать свой репозиторий и обновлять его, когда вздумается
- использовать репозиторий etersoft.ru
- исправить #23878
------- Comment #11 From 2010-12-23 16:08:13 -------
(В ответ на комментарий №7)
> Попробовал:
> ftp://updates.etersoft.ru/pub/ALTLinux/Sisyphus/x86_32/
...
> битную машину. Не удалось. Все еще все сломано?
А что не удалось?
[root@builder64 apt]# apt-get install skype
...
Выбрано skype.32bit для 'skype'
Следующие дополнительные пакеты будут установлены:
  alsa-utils i586-libXScrnSaver.32bit i586-libXcursor.32bit i586-libXi.32bit
i586-libXinerama.32bit i586-libXrandr.32bit i586-libXv.32bit             
  i586-libmng.32bit i586-libqt4-gui.32bit i586-libqt4-network.32bit skype.32bit 
...
0 будет обновлено, 11 новых установлено, 0 пакетов будет удалено и 5 не будет
обновлено.                                                              
...
Продолжить? [Y/n]       

Skype есть в репозитории
ftp://ftp.etersoft.ru/pub/Etersoft/LINUX@Etersoft/Sisyphus i586 addon
ftp://ftp.etersoft.ru/pub/Etersoft/LINUX@Etersoft/Sisyphus noarch addon
------- Comment #12 From 2010-12-23 17:33:15 -------
(В ответ на комментарий №11)
> (В ответ на комментарий №7)
> > Попробовал:
> > ftp://updates.etersoft.ru/pub/ALTLinux/Sisyphus/x86_32/
> ...
> > битную машину. Не удалось. Все еще все сломано?
> А что не удалось?
Скачиваются-то все пакеты нормально, вот дальше:
Следующие пакеты имеют неудовлетворенные зависимости:
  skype.32bit: Требует: /lib/ld-linux.so.2 но пакет не может быть установлен
               Требует: libQtDBus.so.4 (>=
set:mhL33sYgdRF80sa180bWxwpiMgUQ4qCaMfvyA6s637CZ8mjqp2BNxg1)
               Требует: libQtNetwork.so.4 (>=
set:okno7KvZ0lQ3S84lxegTHSqzJ8ROam5XoBdQ0)
E: Извините, `битые' пакеты
------- Comment #13 From 2010-12-23 21:32:18 -------
(В ответ на комментарий №12)
...
>                Требует: libQtDBus.so.4 (>=
> set:mhL33sYgdRF80sa180bWxwpiMgUQ4qCaMfvyA6s637CZ8mjqp2BNxg1)
Видимо, сначала нужно сделать dist-upgrade до Сизифа?
------- Comment #14 From 2010-12-24 06:44:39 -------
(В ответ на комментарий №13)
> (В ответ на комментарий №12)
> ...
> >                Требует: libQtDBus.so.4 (>=
> > set:mhL33sYgdRF80sa180bWxwpiMgUQ4qCaMfvyA6s637CZ8mjqp2BNxg1)
> Видимо, сначала нужно сделать dist-upgrade до Сизифа?

Да, точно. Репозиторий таки работает, прошу прощения за необоснованный наезд.
Хотя скайп таки не ставится, но видимо эта проблема не этой баги. 
Спасибо за разъяснение!
------- Comment #15 From 2011-01-14 13:22:11 -------
i586-libwine-vanilla не обновлялся с прошлого года
------- Comment #16 From 2011-01-17 22:04:55 -------
*** Bug 24925 has been marked as a duplicate of this bug. ***
------- Comment #17 From 2011-01-19 08:28:15 -------
(In reply to comment #15)
> i586-libwine-vanilla не обновлялся с прошлого года

Он не пересобирается (find-requires вываливается, говоря getOutputFrom():
Broken pipe). Когда-нибудь я доберусь посмотреть, почему это происходит.
------- Comment #18 From 2011-02-02 15:45:42 -------
На следующей неделе хотелось бы иметь возможность собрать бету KDesktop-6.0
------- Comment #19 From 2011-02-03 11:09:36 -------
Я бы рад помочь, но, к сожалению, не знаю, как чинить упомянутую ошибку сборки.
------- Comment #20 From 2011-02-03 11:31:17 -------
(В ответ на комментарий №19)
> Я бы рад помочь, но, к сожалению, не знаю, как чинить упомянутую ошибку сборки.

а попросить помощь у Этерсофта? У них некий вариант таки существует?
------- Comment #21 From 2011-02-03 12:07:43 -------
(In reply to comment #17)
> Он не пересобирается (find-requires вываливается, говоря getOutputFrom():
> Broken pipe). Когда-нибудь я доберусь посмотреть, почему это происходит.

А я не это починил пол года назад?
------- Comment #22 From 2011-02-03 14:13:21 -------
(В ответ на комментарий №21)
> > Он не пересобирается (find-requires вываливается, говоря getOutputFrom():
> > Broken pipe). Когда-нибудь я доберусь посмотреть, почему это происходит.
> А я не это починил пол года назад?

Это самое: http://lists.altlinux.org/pipermail/devel/2010-August/184203.html 

Каким-то образом я потерял этот патч, позор на мою голову. Вечером приложу
обратно.
------- Comment #23 From 2011-02-04 13:41:00 -------
А вечер уже наступил?
------- Comment #24 From 2011-02-04 14:48:18 -------
Только что наступил, libwine-vanilla{,-gl} пересобрались. К утру (настоящему,
астрономическому утру) собранные пакеты приползут на FTP.

Баге ставлю WONTFIX, потому что бага была не про libwine-vanilla, а про другое.
------- Comment #25 From 2011-02-04 14:55:51 -------
(В ответ на комментарий №24)
> Баге ставлю WONTFIX
Не имеешь права. Возможно, нужно сменить ответственного.
Давай выясним, кто ответственен за запуск обновления x86_32 так, чтоб оно
выполнялось при синхронно с выкладыванием Сизифа на ftp ?
------- Comment #26 From 2011-02-04 14:58:51 -------
Полагаю, это предмет баги #23878.
------- Comment #27 From 2011-02-04 15:06:16 -------
Смотря как будут реализовывать. C исправлением 23878 вопрос будет исчерпан, но
это сложнее, чем прогонять arepo только перед синхронизацией с внешним ftp,
например.
Думаю, Дима подскажет.
------- Comment #28 From 2011-02-21 21:49:23 -------
Оно даже не каждый день обновляется.
Сегодня 21.02 там i586-libgtk+2-2.24.0-alt1.i586.rpm от 17.02
libgtk+2-2.24.0-alt2 был собран 16.02
------- Comment #29 From 2011-02-21 21:51:16 -------
Может, зарядить все-таки в cron.hourly скрипт не-нужно-ли-обновить-x86-32 ?
------- Comment #30 From 2011-02-21 23:59:10 -------
(In reply to comment #28)
> Оно даже не каждый день обновляется.

Крон-скрипт запускается ежедневно, но в Сизифе постоянно что-то разламывается.
------- Comment #31 From 2011-03-03 14:39:39 -------
Последний разлом 2 недели не починен. Самый свежий пакет там сейчас от
17.02.2011
------- Comment #32 From 2011-03-23 16:37:23 -------
Почему-то сейчас там i586-libwine-vanilla-1.3.10-alt2 и
i586-wine-vanilla-1.3.16-alt1
------- Comment #33 From 2011-03-23 17:30:19 -------
(In reply to comment #32)
> Почему-то сейчас там i586-libwine-vanilla-1.3.10-alt2 и
> i586-wine-vanilla-1.3.16-alt1

Потому что arepo опять не арепит:

* i586-wine-vanilla is not installable:
The following packages have unmet dependencies:
  i586-wine-vanilla.32bit: Depends: i586-libwine-vanilla (= 1.3.16-alt1)
E: Broken packages
------- Comment #34 From 2011-03-30 18:09:16 -------
(В ответ на комментарий №32)
> Почему-то сейчас там i586-libwine-vanilla-1.3.10-alt2 и
> i586-wine-vanilla-1.3.16-alt1
Слыхать что-нибудь?
------- Comment #35 From 2011-03-30 21:35:24 -------
(In reply to comment #34)
> (В ответ на комментарий №32)
> > Почему-то сейчас там i586-libwine-vanilla-1.3.10-alt2 и
> > i586-wine-vanilla-1.3.16-alt1
> Слыхать что-нибудь?

arepo не арепит, нужно звать специалиста по arepo.
------- Comment #36 From 2011-03-30 22:15:25 -------
Гм. Оказывается, все это время из крона запускалась не та версия arepo.py. A
slight forgetfulness on my part. Вайн пересобрался, утром будет.

(Было бы проще, если бы нашёлся человек, которому действительно нужен
беарчь(tm) в альтлинуксе(tm). Я бы ему рассказал всё-всё, что знаю про arepo, и
таких лагов больше не случалось бы.)
------- Comment #37 From 2011-06-10 09:30:21 -------
i586-mozilla-plugin-adobe-flash в данный момент невозможно заставить работать.
------- Comment #38 From 2011-06-10 10:51:37 -------
(В ответ на комментарий №37)
> i586-mozilla-plugin-adobe-flash в данный момент невозможно заставить работать.
Это баги 23876 23877 23878
------- Comment #39 From 2011-06-21 12:23:47 -------
См. тж. bug #25192, comment 11.
------- Comment #40 From 2011-06-24 03:32:14 -------
Кажется, vitty@ благодаря sr@, починил. Закрываю. Открывайте баги по кокретным
проблемам с arepo.
------- Comment #41 From 2011-06-24 13:10:44 -------
Vitty починил 25192
Здесь проблема в том, что x86_32 не синхронихирован с x86_64, поэтому после
любого обновления в x86_64 пакета, фигурирующего в x86_32, он на сутки
становиться разломан при условии что больше не было обновлений, иначе разломан
постоянно, пока они есть, +24 часа.
------- Comment #42 From 2011-06-24 13:13:14 -------
Кстати, Vitty предлагал arepo-вать при сборке. Это бы решило и эту и 23878
------- Comment #43 From 2011-06-25 14:10:16 -------
См. тж. bug #25192, comment 11.
------- Comment #44 From 2011-06-27 17:10:51 -------
(В ответ на комментарий №43)
> См. тж. bug #25192, comment 11.
Да-да, именно это я и имел ввиду.
------- Comment #45 From 2012-04-02 16:59:31 -------
Говорят, в сборочницу интегрирован rpmrebuild-arepo.
------- Comment #46 From 2012-04-02 17:24:37 -------
(В ответ на комментарий №45)
> Говорят, в сборочницу интегрирован rpmrebuild-arepo.
Значит, он тоже такой-же, судя по недавнему разлому в devel@lists или это
слухи.
------- Comment #47 From 2012-04-02 17:29:32 -------
rpmrebuild-arepo интегрирован сегодня, новая архитектура называется i586-x86_64
------- Comment #48 From 2012-04-02 17:32:15 -------
(В ответ на комментарий №47)
> новая архитектура называется i586-x86_64
Давайте срочно поменяем на x86_64-i586 , пока не поздно.
------- Comment #49 From 2012-04-02 19:13:02 -------
Пакет arepo теперь неакуален.
------- Comment #50 From 2012-04-02 19:25:24 -------
Ну и ладно