Bug 25400 - Перестал работать VPN через pptp.
: Перестал работать VPN через pptp.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/NetworkManager-pptp)
: unstable
: all Linux
: P3 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-04-08 11:44 by
Modified: 2011-04-10 02:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-04-08 11:44:18
Стал сегфолтится nm-pptp-pppd-plugin.

/var/log/messages в части касающейся

NetworkManager[4285]: <info> Starting VPN service 'pptp'...
NetworkManager[4285]: <info> VPN service 'pptp' started
(org.freedesktop.NetworkManager.pptp), PID 6490
NetworkManager[4285]: <info> VPN service 'pptp' appeared; activating
connections
NetworkManager[4285]: <info> VPN plugin state changed: 1
NetworkManager[4285]: <info> VPN plugin state changed: 3
NetworkManager[4285]: <info> VPN connection 'My-VPN' (Connect) reply received.
pppd[6492]: Plugin /usr/lib/pppd/2.4.5/nm-pptp-pppd-plugin.so loaded.
pppd[6492]: pppd 2.4.5 started by root, uid 0
pppd[6492]: Using interface ppp1
pppd[6492]: Connect: ppp1 <--> /dev/pts/2
pptp[6494]: nm-pptp-service-6490 log[main:pptp.c:314]: The synchronous pptp
option is NOT activated 
pptp[6498]: nm-pptp-service-6490 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control
packet type is 1 'Start-Control-Connection-Request' 
pptp[6498]: nm-pptp-service-6490 log[ctrlp_disp:pptp_ctrl.c:739]: Received
Start Control Connection Reply
pptp[6498]: nm-pptp-service-6490 log[ctrlp_disp:pptp_ctrl.c:773]: Client
connection established.
pptp[6498]: nm-pptp-service-6490 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control
packet type is 7 'Outgoing-Call-Request' 
pptp[6498]: nm-pptp-service-6490 log[ctrlp_disp:pptp_ctrl.c:858]: Received
Outgoing Call Reply.
pptp[6498]: nm-pptp-service-6490 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call
established (call ID 0, peer's call ID 62). 
NetworkManager[4285]: <warn> VPN service 'pptp' died with signal 11
kernel: nm-pptp-service[6490]: segfault at 0 ip 0804ab2b sp bfcc46d0 error 4 in
nm-pptp-service[8048000+6000]
pppd[6492]: Unable to obtain CHAP password for *** on ***       from plugin


Если откатить NetworkManager на 0.8.2-alt2.git20101126 - все работает.
------- Comment #1 From 2011-04-09 04:59:39 -------
Воспроизвел, скоро починю.
------- Comment #2 From 2011-04-09 15:16:44 -------
(В ответ на комментарий №1)
> Воспроизвел, скоро починю.
Ок спасибо.
Приношу извинения за bloker (случайно зацепил).

[JT]

Еще-бы ModemManager (#24110) починить...

С учетом этой ошибки + #24110 + #25297 (последнее особенно достало)
не выдержал и перенастроил сеть на etcnet с выносом NM.
Все просто работает, Причем (субъективно) значительно быстрее чем было, ну и
соответственно без перечисленных глюков, правда через ifup/ifdown.


Да, и еще, сильно удивило:

sudo apt-get remove NetworkManager-glib
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  NetworkManager-glib gimp google-gadgets-core google-gadgets-qt
google-gadgets-xul kde4artwork-desktopthemes kde4artwork-screensavers
  kde4artwork-screensavers3d kde4artwork-xscreensaver
kde4artwork-xscreensaver3d kde4base-workspace kde4base-workspace-core
libgeoclue libgoogle-gadgets
  libgoogle-gadgets-qt libwebkitgtk2 plasma-applet-binaryclock
plasma-applet-blackboard plasma-applet-bookmarks plasma-applet-bubblemon
  plasma-applet-calculator plasma-applet-charselect plasma-applet-dict
plasma-applet-eyes plasma-applet-fifteenpuzzle plasma-applet-filewatcher
  plasma-applet-frame plasma-applet-fuzzy-clock plasma-applet-incomingmsg
plasma-applet-kimpanel plasma-applet-knowledgebase plasma-applet-kolourpicker
  plasma-applet-konqprofiles plasma-applet-lancelot plasma-applet-leavenote
plasma-applet-news plasma-applet-notes plasma-applet-paste
  plasma-applet-pastebin plasma-applet-plasmaboard plasma-applet-previewer
plasma-applet-qalculate plasma-applet-rssnow plasma-applet-showdashboard
  plasma-applet-showdesktop plasma-applet-systemloadviewer
plasma-applet-unitconverter plasma-applet-weather plasma-applet-webslice
  plasma-dataengine-microblog plasma-dataengine-potd
plasma-runner-audioplayercontrol plasma-runner-browserhistory
plasma-runner-charrunner
  plasma-runner-contacts plasma-runner-converter plasma-runner-datetime
plasma-runner-katesessions plasma-runner-konquerorsessions
  plasma-runner-konsolesessions plasma-runner-kopete
0 upgraded, 0 newly installed, 61 removed and 1 not upgraded.
------- Comment #3 From 2011-04-09 16:42:28 -------
(В ответ на комментарий №2)
> [JT]
> 
> Еще-бы ModemManager (#24110) починить...

С этим хорошо бы сходить к апстриму. Мне писать апстриму вряд ли имеет смысл,
без железки я не смогу ответить на вопросы. Я копался в MM на предмет этой
баги, но уже давно и времени на более глубокое копание не было.
На следующей неделе я планирую собрать свежий snapshot MM, будет имеет смысл
проверить с ним. Я, правда, не помню там обнадеживающих коммитов, но я не
слишком внимательно следил за ним в последнее время.

> Да, и еще, сильно удивило:

Разный софт имеет поддержку NM, спрашивая у него о наличии сети, например.
------- Comment #4 From 2011-04-09 20:22:59 -------
(В ответ на комментарий №3)
> С этим хорошо бы сходить к апстриму. 
Мрачно занят :-(
Проще сеть перенастроить.


> На следующей неделе я планирую собрать свежий snapshot MM, будет имеет смысл
> проверить с ним. 
Попробуем.

> > Да, и еще, сильно удивило:
> > ... 
> Разный софт имеет поддержку NM, спрашивая у него о наличии сети, например.

И кому тут оно реально надо?

kde4base-workspace-core -> libgoogle-gadgets -> libwebkitgtk2 -> libgeoclue ->
libnm-glib.so.2. 

Хотя с этим наверное в sisyphus@
------- Comment #5 From 2011-04-10 02:11:30 -------
NetworkManager-pptp-0.8.3.999-alt1.git20110404 -> sisyphus:

* Sat Apr 09 2011 Mikhail Efremov <sem@altlinux> 0.8.3.999-alt1.git20110404
- upstream git snapshot (NM_0_8 branch):
    + fix crash (closes: #25400).