Bug 25455 - Мусор на экране при инсталляции на NVIDIA GeForce 7025/ nForce 630a
: Мусор на экране при инсталляции на NVIDIA GeForce 7025/ nForce 630a
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/installer)
: unstable
: x86_64 Linux
: P3 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-04-16 22:10 by
Modified: 2013-11-24 21:03 (History)


Attachments
Мусор на экране (22.59 KB, image/jpeg)
2011-04-16 22:10, tu13@fromru.com
no flags Details
lspci из-под Ubuntu 10.10 64bit (2.68 KB, text/plain)
2011-04-18 19:55, tu13@fromru.com
no flags Details
лог X-сервера (37.15 KB, application/octet-stream)
2011-04-19 10:34, tu13@fromru.com
no flags Details
лог X от LiveCD Ubuntu 10.10 64bit (40.95 KB, application/octet-stream)
2011-04-19 11:50, tu13@fromru.com
no flags Details
Xorg.log от altlinux-6.0-alpha2-lxdesktop-i586 (21.68 KB, application/octet-stream)
2011-04-24 18:55, tu13@fromru.com
no flags Details
Xorg.log от altlinux-6.0.0_beta-20110429-kdesktop-x86_64 (10.78 KB, application/octet-stream)
2011-05-02 14:24, tu13@fromru.com
no flags Details
Мелкий шрифт (13.74 KB, image/jpeg)
2011-05-02 14:27, tu13@fromru.com
no flags Details
Мусор на экране в 6.0 (55.45 KB, image/jpeg)
2011-05-24 20:52, tu13@fromru.com
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-04-16 22:10:28
Created an attachment (id=4893) [details]
Мусор на экране

При загрузке в LiveCD при переходе в режим XGA игнорируются сведения о
возможностях монитора. В эксперимента использовалась m/b на чипсете NVIDIA
GeForce 7025/ nForce 630a и монитор Samsung 913BM (1280*1024 75Hz). В
результате на экране "мусор" по всей площади. Те же симптомы при попытке
инсталляции и том же переходе в режим XGA на очередном шаге.
------- Comment #1 From 2011-04-16 22:23:32 -------
Образ с проблемой:
5.9.9-20110401-centaurus-x86_64-ru-install-dvd5
------- Comment #2 From 2011-04-17 06:00:30 -------
(В ответ на комментарий №0)
> Created an attachment (id=4893) [details] [details]
> Мусор на экране
> 
> При загрузке в LiveCD при переходе в режим XGA игнорируются сведения о
> возможностях монитора. В эксперимента использовалась m/b на чипсете NVIDIA
> GeForce 7025/ nForce 630a и монитор Samsung 913BM (1280*1024 75Hz). В
> результате на экране "мусор" по всей площади. Те же симптомы при попытке
> инсталляции и том же переходе в режим XGA на очередном шаге.

Какая видеокарта?
------- Comment #3 From 2011-04-17 09:37:45 -------
(В ответ на комментарий №2)

> Какая видеокарта?

GeForce 7025 - в чипсете указана
------- Comment #4 From 2011-04-17 20:16:46 -------
При любом варианте инсталляции (обычный/безопасный и все варианты по F5 для
ядра) после сообщения "Загрузка информации о пакетах" рядом с прогресс-баром
вылетает отдельным экраном: 

Критическая ошибка установки
Warning: Actual size:     3925
Warning: Expected size:   28940=lead(96)+sigs(248)+pad(0)+data(28596)

После этого "Далее" уже не двигает прогресс-бар (экран возвращается, процесс не
движется). "Назад" вызывает завершение работы Х-сервера, ругань на
отсутствующие скрипты и автоперезагрузку.
------- Comment #5 From 2011-04-17 20:25:41 -------
(В ответ на комментарий №4)
> При любом варианте инсталляции (обычный/безопасный и все варианты по F5 для
> ядра) после сообщения "Загрузка информации о пакетах" рядом с прогресс-баром
> вылетает отдельным экраном: 
> 
> Критическая ошибка установки
> Warning: Actual size:     3925
> Warning: Expected size:   28940=lead(96)+sigs(248)+pad(0)+data(28596)
> 
> После этого "Далее" уже не двигает прогресс-бар (экран возвращается, процесс не
> движется). "Назад" вызывает завершение работы Х-сервера, ругань на
> отсутствующие скрипты и автоперезагрузку.

А вот это уже похоже на проблемы битого образа, ошибки записи носителя или
привода.
Проверьте MD5SUM для начала.
------- Comment #6 From 2011-04-17 21:40:50 -------
(В ответ на комментарий №5)

> А вот это уже похоже на проблемы битого образа, ошибки записи носителя или
> привода.
> Проверьте MD5SUM для начала.

bcca1093d9d02c0d34cf507b96f5d842 
altlinux-5.9.9-20110401-centaurus-x86_64-ru-install-dvd5.iso
Совпадает. Носитель перепробован не один уже, привода два (внешний USB и
внутренний SATA)
------- Comment #7 From 2011-04-18 13:04:35 -------
А на этом железе другие ОС (win, другие дистрибутивы linux) работают нормально?
------- Comment #8 From 2011-04-18 13:09:22 -------
это или разогнанный процессор, или плохое охлаждение, или битая память.

Проблема очень похожа на аппаратную. Проверьте, пожалуйста, работают ли другие
дистрибутивы. Например не кентавр, а kdesktop или server-light.
------- Comment #9 From 2011-04-18 19:55:22 -------
Created an attachment (id=4898) [details]
lspci из-под Ubuntu 10.10
------- Comment #10 From 2011-04-18 19:58:31 -------
(From update of attachment 4898 [details])
Ubuntu 10.10 64bit
------- Comment #11 From 2011-04-18 20:03:23 -------
(From update of attachment 4898 [details])
Сейчас на основном HDD установлен Win7 32bit, на втором HDD установил Ubuntu,
даю вывод lspci из-под Ubuntu 10.10 64bit
------- Comment #12 From 2011-04-18 20:07:44 -------
(From update of attachment 4898 [details])
Сейчас на основном HDD установлен Win7 32bit, на втором HDD установил Ubuntu,
даю вывод lspci из-под Ubuntu 10.10 64bit
------- Comment #13 From 2011-04-19 09:02:28 -------
После записи на пятую (!) болванку система установилась. Болванки были
перепробованы DVD-R 16х разных производителей и разных серий. Привод не
виноват, т.к. на нём пишутся все дистрибутивы и это первый со сбоем. Кстати,
все остальные дистрибутивы пишутся на изначально выбранные болванки.
------- Comment #14 From 2011-04-19 09:49:08 -------
Виноват, поторопился.
Рассказываю подробно: 4 болванки я гонял на тестовой машине, а пятую проверил
на "виртуалбоксе". После этого пятую поставил в тестовую машину и.... Тот же
эффект мусора при стандартной установке и LiveCD. Сейчас устанавливаю в
безопасном режиме.
------- Comment #15 From 2011-04-19 10:34:26 -------
Created an attachment (id=4901) [details]
лог X-сервера

Установил в безопасном режиме. Результат выполнения startx прилагаю.
------- Comment #16 From 2011-04-19 11:50:53 -------
Created an attachment (id=4902) [details]
лог X от LiveCD Ubuntu 10.10 64bit

По просьбе asy : лог X от LiveCD Ubuntu 10.10 64bit
------- Comment #17 From 2011-04-24 18:55:28 -------
Created an attachment (id=4909) [details]
Xorg.log от altlinux-6.0-alpha2-lxdesktop-i586

С i586 дистрибутивом 5.9.9 от 1 апреля история та же, что и с х64. Проверил
LiveCD, получил мусор. Курсор-стрелочка бегает поверх него. 
По просьбе asy проверил LiveCD от Радика
(ftp://ftp.altlinux.org/pub/people/radik/iso/testing/). Загрузилось, Xorg.log
прилагаю.
------- Comment #18 From 2011-04-24 19:08:44 -------
Пока для Вашей карты ставится драйвер nouveau, результата, видимо, не будет.
Обсуждаем эту проблему. Вам -- спасибо.
------- Comment #19 From 2011-04-24 20:42:23 -------
Мне тут кое-что непонятно. В первом xorg.log, который был получен после
установки 20110401-centaurus-x86_64 в безопасном режиме (как автор бага пишет),
присутствует строка: 
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-std-def-alt1
Во-первых, не очень понятно, почему ядро получилось не el-smp (в инсталяторе
выбор есть ? я сам Кентавра не ставил ещё), во-вторых, получается, что
изменения, устраняющие ошибку загрузки nouveau, произошли недавно совсем ? Ведь
у alpha2-lxdesktop ядро 2.6.38-std-def-alt2, а грузится уже.
------- Comment #20 From 2011-05-02 14:24:51 -------
Created an attachment (id=4916) [details]
Xorg.log от altlinux-6.0.0_beta-20110429-kdesktop-x86_64

В новой сборке altlinux-6.0.0_beta-20110429-kdesktop-x86_64-ru-install-dvd5.iso
загрузился LiveCD. И видеочип определился, и "монитор" в виде телевизора.
------- Comment #21 From 2011-05-02 14:27:16 -------
Created an attachment (id=4917) [details]
Мелкий шрифт

Добавлю только про досадный недостаток. Шрифт при таком разрешении выбрался
слишком мелкий. Фото прилагаю. Простите за муар - под рукой был только
мобильный телефон.
------- Comment #22 From 2011-05-02 14:35:07 -------
(В ответ на комментарий №21)
> Created an attachment (id=4917) [details] [details]
> Мелкий шрифт
> 
> Добавлю только про досадный недостаток. Шрифт при таком разрешении выбрался
> слишком мелкий. Фото прилагаю. Простите за муар - под рукой был только
> мобильный телефон.

Пожалуйста, откройте новую багу на эту тему. 
Если возможно, попробуйте еще бету Centaurus, которая выйдет после
праздников(!), прежде чем окончательно закрывать эту.
Спасибо!
------- Comment #23 From 2011-05-02 15:12:38 -------
(В ответ на комментарий №1)
> Образ с проблемой:
> 5.9.9-20110401-centaurus-x86_64-ru-install-dvd5

2boyarsh: Антон, обратите внимание на лог, -- модуль ядра nouveau не
загружается.
------- Comment #24 From 2011-05-24 20:52:23 -------
Created an attachment (id=4954) [details]
Мусор на экране в 6.0

Попробовал altlinux-6.0.0-20110517-centaurus-x86_64-ru-install-dvd5.
Запустил LiveCD, получил то же самое на экране, что и в исходном сообщении.
Стрелка всё так же поверх мусора чёткая.
------- Comment #25 From 2011-10-14 11:30:21 -------
(In reply to comment #18)
> Пока для Вашей карты ставится драйвер nouveau, результата, видимо, не будет.
Если что, у меня есть под руками такая машинка, после шести по Киеву можно
экспериментировать.
------- Comment #26 From 2011-12-17 01:59:48 -------
"После шести" настало, взял машинку с gf7025/nf630a (видимо, тот же самый
biostar) и 17" 1280x1024 (правда, это LG L1753S), загрузил с флэшки
altlinux-6.0.1_rc2-simply-i586-ru-live-cd.iso -- мусора не наблюдаю; загрузил
самосборный инсталятор (подвернулась под руку сентябрьская сборка на сизифе) --
тоже всё в порядке.

Так что проверять конкретно эту багу придётся конкретно на Вашем
оборудовании...

PS: если будет удобно, гляньте
http://beta.altlinux.com/p6/simply/altlinux-6.0.1_rc2-simply-i586-ru-live-cd.iso
http://lists.altlinux.org/pipermail/community/2011-December/674057.html
------- Comment #27 From 2011-12-17 18:35:32 -------
(В ответ на комментарий №26)

> PS: если будет удобно, гляньте
> http://beta.altlinux.com/p6/simply/altlinux-6.0.1_rc2-simply-i586-ru-live-cd.iso
> http://lists.altlinux.org/pipermail/community/2011-December/674057.html

Да, на релиз-кандидатах эта бага не проявляется. И в указанном Вами, и том, что
в 20 комментарии (6-бета). Странно, что в 6.0.0 вылезала.
------- Comment #28 From 2012-12-17 17:12:04 -------
(In reply to comment #27)

У Михаила Шигорина ссылка, во-первых, на релиз-кандидат Simply, а не Centaurus,
во-вторых, речь про Simply 6.0.1, а у Centaurus версия рассматривалась 6.0.0.
Хотя, на самом деле, по этим цифрам в версиях разных дистрибутивов тоже нельзя
судить, кто из них новее.
------- Comment #29 From 2013-11-24 21:03:55 -------
(In reply to comment #27)
> Да, на релиз-кандидатах эта бага не проявляется. И в указанном Вами, и том,
> что в 20 комментарии (6-бета). Странно, что в 6.0.0 вылезала.
Предлагаю закрыть как WORKSFORME.