Bug 25846 - Не работает cron-задача
: Не работает cron-задача
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/vixie-cron)
: unstable
: all Linux
: P3 critical
Assigned To:
:
: http://git.altlinux.org/people/ldv/pa...
:
:
:
  Show dependency tree
 
Reported: 2011-07-02 08:33 by
Modified: 2011-07-15 18:10 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-07-02 08:33:32
После обновления stmpclean пришла ругань от крона:
Subject: Cron <root@evg> run-parts /etc/cron.daily
/etc/cron.daily/stmpclean: line 5: stmpclean: command not found
/etc/cron.daily/stmpclean: line 7: stmpclean: command not found
/etc/cron.daily/stmpclean: line 10: stmpclean: command not found
------- Comment #1 From 2011-07-02 11:41:26 -------
Как так получилось, что /usr/sbin пропал из $PATH?
------- Comment #2 From 2011-07-02 16:33:27 -------
Понятия не имею. А он там был?

Глупый, вопрос, но где должен добавляться sbin в $PATH неинтерактивного шелла?
Мои скромные грепы результата не дали.
------- Comment #3 From 2011-07-07 17:32:20 -------
/sbin и /usr/sbin должны быть в $PATH у root без дополнительных телодвижений.
Перевешиваю на crond.
------- Comment #4 From 2011-07-07 23:28:36 -------
vixie-cron-4.1.20060426-alt8 -> sisyphus:

* Thu Jul 07 2011 Dmitry V. Levin <ldv@altlinux> 4.1.20060426-alt8
- Added SELinux support (by Mikhail Efremov).
- crond: added systemd support (by Alexey Shabalin; closes: #25463).
- crond: changed default $PATH to something reasonable (closes: #25846).
------- Comment #5 From 2011-07-15 18:10:59 -------
*** Bug 25911 has been marked as a duplicate of this bug. ***