Bug 26014 - xulrunner-5.0 must have versioned dependency on xulrunner-libs-5.0
: xulrunner-5.0 must have versioned dependency on xulrunner-libs-5.0
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xulrunner-5.0)
: unstable
: all Linux
: P3 blocker
Assigned To:
:
:
:
:
: 23155
  Show dependency tree
 
Reported: 2011-08-09 13:00 by
Modified: 2011-08-09 23:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-08-09 13:00:12
[vostok@localhost ~]$ firefox                                                   
Error: Platform version '2.0.1' is not compatible with                          
minVersion >= 5.0.1                                                             
maxVersion <= 5.0.1  

Прочитал:
http://kb.mozillazine.org/Browser_will_not_start_up#XULRunner_error_after_an_update

Снёс полностью firefox, xulrunner, подвинул ~/.mozilla/firfox

Ничего не помогает.
Почините, пожалуйста, firefox :)
------- Comment #1 From 2011-08-09 14:58:53 -------
apt> install xulrunner-5.0-libs
Unrequested changes are needed to execute this operation.
The following packages will be REPLACED:
  xulrunner-2.0-libs (by xulrunner-5.0-libs)
The following NEW packages will be installed:
  xulrunner-5.0-libs

Решает проблему.
------- Comment #2 From 2011-08-09 15:07:47 -------
(В ответ на комментарий №1)
> apt> install xulrunner-5.0-libs
>   xulrunner-2.0-libs (by xulrunner-5.0-libs)
> Решает проблему.

Да, спасибо. Не заметил что в Сизифе две версии xulrunner-libs оказалось.
------- Comment #3 From 2011-08-09 17:49:34 -------
*** Bug 26015 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2011-08-09 23:58:14 -------
xulrunner-5.0-5.0.1-alt2 -> sisyphus:

* Tue Aug 09 2011 Alexey Gladkov <legion@altlinux> 5.0.1-alt2
- Fix requires (ALT#26014).