Bug 2708 - cups web interface screws URLs
: cups web interface screws URLs
Status: CLOSED DUPLICATE of bug 2236
: Sisyphus
(All bugs in Sisyphus/cups)
: unstable
: all Linux
: P4 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-06-26 18:35 by
Modified: 2005-04-23 00:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-06-26 18:35:06
web interface (port 631) would try to \"sanitize\" URLs in some
cases, e.g. when trying to print the testpage:

accessing \"Print Test Page\" from 

  <a href="http://localhost:631/printers">http://localhost:631/printers</a> 

would result in redirect to (say):

  <a
href="http://trickster.inmetex:631/printers/lp?op=print-test-page">http://trickster.inmetex:631/printers/lp?op=print-test-page</a>

which just won\'t work (100%, see \&quot;localhost only\&quot; access
restrictions).


---

---
Have to fix that in some way or another, preferably _before_ Junior 2.3.  Thus
\&quot;block\&quot;.
------- Comment #1 From 2003-10-08 12:34:06 -------

*** This bug has been marked as a duplicate of 2236 ***
------- Comment #2 From 2005-04-23 00:37:56 -------
давно закрыт