Bug 27367 - apt does not resolve versioned perl dependency with slash
: apt does not resolve versioned perl dependency with slash
Status: CLOSED DUPLICATE of bug 26668
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-05-24 22:22 by
Modified: 2012-07-12 01:34 (History)


Attachments
example rpm file (11.84 KB, application/x-rpm)
2012-05-24 22:22, viy
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-05-24 22:22:27
Created an attachment (id=5472) [details]
example rpm file

с перловыми зависимостями со слешем вылезла еще одна проблема, похожая на
https://bugzilla.altlinux.org/show_bug.cgi?id=27364

Есть пакет с BuildRequires:  perl(Test/More.pm) >= 0.01
Есть соответствующий Provides: в perl-base
rpmquery --provides perl-devel G Test/More                      
perl(Test/More.pm) = 0.980
но сборка обламывается:

hsh ./OUT/perl-accessors-1.01-alt1_9.src.rpm
Чтение списков пакетов...
Построение дерева зависимостей...
Выбрано perl-base для 'perl(Benchmark.pm)'
Последняя версия perl-base уже установлена.
Выбрано perl-base для 'perl(base.pm)'
Последняя версия perl-base уже установлена.
Выбрано perl-base для 'perl(warnings/register.pm)'
Последняя версия perl-base уже установлена.
Version perl-base#1:5.14.2-alt4 for perl>=1:5.6.0 is already installed
Последняя версия perl-base уже установлена.
Выбрано perl-Module-Build для 'perl(Module/Build.pm)'
E: Couldn't find package perl(Test/More.pm)>=0.01
hsh-install: Failed to calculate package file list.
hsh-install: Failed to generate package file list.
------- Comment #1 From 2012-05-24 22:27:54 -------
I suspect that apt incorrectly mangles perl(Test/More.pm) >= 0.01 to
"perl(Test"
and then can not resolve "perl(Test" in Provides.
------- Comment #2 From 2012-05-24 23:42:08 -------
At the same time, the perl dependencies with slash but without version,
like `perl(Module/Build.pm)' are handled properly.
------- Comment #3 From 2012-05-25 15:06:12 -------
Also, apt handle versioned perl requires correctly:
Requires: perl(Catalyst/Runtime.pm) >= 5.800.300
does work.

So, the only place it does not work is BuildRequires:.
------- Comment #4 From 2012-07-12 01:34:22 -------
Already reported.

*** This bug has been marked as a duplicate of bug 26668 ***